aboutsummaryrefslogtreecommitdiff
path: root/japanese/today/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-10-18 15:04:50 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-10-18 15:04:50 +0000
commit9ae6f48b553a50813e525a0eaea80ac020fafe59 (patch)
tree4ff3c0c90cfe3b09f683f0a3ea74c61e82fe9b1d /japanese/today/Makefile
parent4c8b5a5f58a07b4e6eb0e83a75df64114b2cb3f1 (diff)
downloadports-9ae6f48b553a50813e525a0eaea80ac020fafe59.tar.gz
ports-9ae6f48b553a50813e525a0eaea80ac020fafe59.zip
Tells you what day today is.
Submitted by: ABURAYER Rewsirow <pcs51674@asciinet.or.jp>
Notes
Notes: svn path=/head/; revision=4033
Diffstat (limited to 'japanese/today/Makefile')
-rw-r--r--japanese/today/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/japanese/today/Makefile b/japanese/today/Makefile
new file mode 100644
index 000000000000..d6079561d2fb
--- /dev/null
+++ b/japanese/today/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: today
+# Version required: 2.10b
+# Date created: 24 June 1996
+# Whom: ABURAYER Rewsirow <pcs51674@asciinet.or.jp>
+#
+# $Id$
+#
+
+DISTNAME= td210bs
+PKGNAME= jp-today-2.10b
+CATEGORIES+= japanese games
+MASTER_SITES= ftp://ftp.waseda.ac.jp/pub/archive/fj.binaries.msdos/
+
+DISTFILES= td210bs.lzh td210bm.lzh
+
+MAINTAINER= pcs51674@asciinet.or.jp
+
+BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha
+BUILD_DEPENDS+= nkf:${PORTSDIR}/japanese/nkf
+
+EXTRACT_CMD= lha
+EXTRACT_SUFX= .lzh
+EXTRACT_BEFORE_ARGS= xfw=${WRKDIR}
+NO_WRKSUBDIR= yes
+PATCH_STRIP= -p1
+
+post-extract:
+ @echo "===> Extracting tbl file for ${DISTNAME}"
+ @(cd ${WRKDIR}; lha xf tbl.lzh )
+ @echo "===> Renaming file for ${DISTNAME}"
+ @(cd ${WRKDIR}; \
+ mv rdcalend.c rdcalendar.c ; \
+ mv rdcalend.h rdcalendar.h )
+ @echo "===> Converting Kanji code for ${DISTNAME}"
+ @(cd ${WRKDIR}; \
+ for i in *.c *.h *.doc *.cnf birthday.tbl event*.tbl flower.tbl \
+ gengo.tbl hist??.tbl history.tbl holiday.tbl magazin.tbl \
+ monthly.tbl week.tbl; \
+ do \
+ echo $$i ; \
+ sed 's/.$$//' $$i | nkf -e > $$i.tmp ;\
+ mv -f $$i.tmp $$i ; \
+ done)
+
+pre-patch:
+ @echo "===> Installing custom Makefile for ${DISTNAME}"
+ @(cp ${FILESDIR}/Makefile ${WRKSRC})
+
+.include <bsd.port.mk>