aboutsummaryrefslogtreecommitdiff
path: root/lang/cocor/files
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2009-03-25 12:35:49 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2009-03-25 12:35:49 +0000
commit578a084158e82c07af6b0ea8f60bc118fe5f20f9 (patch)
tree042ff878f6f465b2914e79a28b0637ad947ec843 /lang/cocor/files
parent127c2957dc0be71440acb8d617195b744f04ceca (diff)
Notes
Diffstat (limited to 'lang/cocor/files')
-rw-r--r--lang/cocor/files/patch-taste-unix.mk29
-rw-r--r--lang/cocor/files/patch-taste_cp::unix.mk31
2 files changed, 58 insertions, 2 deletions
diff --git a/lang/cocor/files/patch-taste-unix.mk b/lang/cocor/files/patch-taste-unix.mk
new file mode 100644
index 000000000000..d6ddd8c3fcac
--- /dev/null
+++ b/lang/cocor/files/patch-taste-unix.mk
@@ -0,0 +1,29 @@
+--- taste/unix.mk.orig 2009-03-25 13:30:16.000000000 +0100
++++ taste/unix.mk 2009-03-25 13:30:36.000000000 +0100
+@@ -27,7 +27,7 @@
+ $(CC) $(CFLAGS) -otaste taste.o tl.o tc.o\
+ tastes.o tastep.o
+
+-tastep.o: taste.atg
++tastep.o taste.o: taste.atg
+ $(COCOR) taste.atg
+ $(CC) $(CFLAGS) -c taste.c tastep.c tastes.c
+
+@@ -35,7 +35,7 @@
+ $(CC) $(CFLAGS) -opretty pretty.o prettypr.o \
+ prettys.o prettyp.o
+
+-prettyp.o: pretty.atg
++prettyp.o pretty.o: pretty.atg
+ $(COCOR) pretty.atg
+ $(CC) $(CFLAGS) -c pretty.c prettyp.c prettys.c
+
+@@ -43,7 +43,7 @@
+ $(CC) $(CFLAGS) -oxref xref.o crossref.o \
+ xrefs.o xrefp.o
+
+-xrefp.o: xref.atg
++xrefp.o xref.o: xref.atg
+ $(COCOR) xref.atg
+ $(CC) $(CFLAGS) -c xref.c xrefp.c xrefs.c
+
diff --git a/lang/cocor/files/patch-taste_cp::unix.mk b/lang/cocor/files/patch-taste_cp::unix.mk
index b723ce5105ef..c44cc34badeb 100644
--- a/lang/cocor/files/patch-taste_cp::unix.mk
+++ b/lang/cocor/files/patch-taste_cp::unix.mk
@@ -1,5 +1,5 @@
---- taste_cp/unix.mk.orig Sat Jan 18 01:58:29 2003
-+++ taste_cp/unix.mk Sat Jan 18 01:59:37 2003
+--- taste_cp/unix.mk.orig 2009-03-25 13:31:23.000000000 +0100
++++ taste_cp/unix.mk 2009-03-25 13:33:00.000000000 +0100
@@ -8,17 +8,17 @@
#CC sets the name of the compiler to use (cc, gcc, etc)
@@ -21,3 +21,30 @@
$(CC) -c $(CFLAGS) $< -o $@
all: taste pretty xref
+@@ -38,7 +38,7 @@
+ $(CC) $(CFLAGS) -otaste taste.o tl.o tc.o\
+ tastes.o tastep.o $(LIB)
+
+-tastep.o: taste.atg
++tastep.o taste.o: taste.atg
+ $(COCOR) taste.atg
+ $(CC) $(CFLAGS) -c taste.c?? tastep.c?? tastes.c??
+
+@@ -46,7 +46,7 @@
+ $(CC) $(CFLAGS) -opretty pretty.o prettypr.o \
+ prettys.o prettyp.o $(LIB)
+
+-prettyp.o: pretty.atg
++prettyp.o pretty.o: pretty.atg
+ $(COCOR) pretty.atg
+ $(CC) $(CFLAGS) -c pretty.c?? prettyp.c?? prettys.c??
+
+@@ -54,7 +54,7 @@
+ $(CC) $(CFLAGS) -oxref xref.o crossref.o \
+ xrefs.o xrefp.o $(LIB)
+
+-xrefp.o: xref.atg
++xrefp.o xref.o: xref.atg
+ $(COCOR) xref.atg
+ $(CC) $(CFLAGS) -c xref.c?? xrefp.c?? xrefs.c??
+