aboutsummaryrefslogtreecommitdiff
path: root/lang/gnu-cobol
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-08 19:22:29 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-08 19:22:29 +0000
commitee2f8d2d50a27c822bb2559c9c22ba2cc54c02b9 (patch)
tree6fa55fe68d057368acff15a6ecea7a1ec24b6fa3 /lang/gnu-cobol
parentbab6f180ebb072b6d3150f85027a9274e323af12 (diff)
downloadports-ee2f8d2d50a27c822bb2559c9c22ba2cc54c02b9.tar.gz
ports-ee2f8d2d50a27c822bb2559c9c22ba2cc54c02b9.zip
lang/gnu-cobol: document ncurses requirement (USES+=ncurses)
Also link with ncurses, not curses approved by: infrastructure blanket
Notes
Notes: svn path=/head/; revision=408506
Diffstat (limited to 'lang/gnu-cobol')
-rw-r--r--lang/gnu-cobol/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/gnu-cobol/Makefile b/lang/gnu-cobol/Makefile
index 3aac3257f0fe..1f46f09b897c 100644
--- a/lang/gnu-cobol/Makefile
+++ b/lang/gnu-cobol/Makefile
@@ -13,7 +13,7 @@ COMMENT= Open-source COBOL compiler
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
USE_BDB= yes
-USES= gmake libtool
+USES= gmake libtool ncurses
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -30,6 +30,7 @@ CONFIGURE_ENABLE=nls
post-patch:
@${REINPLACE_CMD} -e 's|__gmp_randinit|__gmpz_init|g ; \
s|db-4.[0-9]|${BDB_LIB_NAME}|g ; \
+ s|-lcurses|-lncurses|g ; \
s|-R$$found_dir|-Wl,-rpath,$$found_dir|g' ${WRKSRC}/configure
.include <bsd.port.mk>