aboutsummaryrefslogtreecommitdiff
path: root/lang/gscheme/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-18 09:55:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-18 09:55:59 +0000
commit935421d20f0298fe6ee095537b94ae0715577648 (patch)
treeae201c6746deb392fa1ad7a5816079cb9e4d9a77 /lang/gscheme/Makefile
parent577d359b5f27de779ac35847900c58fb2c20703b (diff)
downloadports-935421d20f0298fe6ee095537b94ae0715577648.tar.gz
ports-935421d20f0298fe6ee095537b94ae0715577648.zip
A GNUstep-aware scheme interpreter. You need libflex installed on your system.
Includes many examples, e.g. the sieve of Erathostenes to compute primes, a Koch curve plotter, mandelbrot set, graphs of various functions etc. GScheme is fully tail recursive. The garbage collector bypasses GNUstep's retain/release mechanism in order to deal with circular data structures. GScheme is document-based and you can edit more than one file at the same time. WWW: http://www.gnustep.it/marko/GScheme/index.html
Notes
Notes: svn path=/head/; revision=177497
Diffstat (limited to 'lang/gscheme/Makefile')
-rw-r--r--lang/gscheme/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/gscheme/Makefile b/lang/gscheme/Makefile
new file mode 100644
index 000000000000..4d78331b9d2b
--- /dev/null
+++ b/lang/gscheme/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gscheme
+# Date created: 17 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gscheme
+PORTVERSION= 0.5
+CATEGORIES= lang
+MASTER_SITES= http://www.gnustep.it/marko/GScheme/
+DISTNAME= GScheme
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= GNUstep-aware scheme interpreter
+
+#WRKSRC= ${WRKDIR}/X
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+ALL_TARGET=
+
+post-install:
+ ${RM} -f ${GNUSTEP_PREFIX}/Local/Applications/GScheme.app/Resources/library.scm~
+
+.include <bsd.port.mk>