aboutsummaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-06 06:32:22 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-06 06:32:22 +0000
commit7cdc62b981ecfcc26a72eb00e704f0180853de99 (patch)
tree9e0e39ea77f4f75a3e4e404bd0bbbe59e137f66c /lang/python32/Makefile
parentc54b783cab509fc7826a56aff6e5728e5036c17a (diff)
downloadports-7cdc62b981ecfcc26a72eb00e704f0180853de99.tar.gz
ports-7cdc62b981ecfcc26a72eb00e704f0180853de99.zip
Notes
Diffstat (limited to 'lang/python32/Makefile')
-rw-r--r--lang/python32/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 5208a60c49a7..7a571d38f971 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -53,6 +53,17 @@ OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
@@ -68,15 +79,6 @@ PLIST_SUB+= IF_DEFAULT_MAJOR=""
PLIST_SUB+= IF_DEFAULT_MAJOR="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads