aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby_static
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-05-06 16:46:05 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-05-06 16:46:05 +0000
commit99c64a19db42a1a7d016a3efed56a7649b2ba518 (patch)
tree1b067a9a1715f680a3cf12d3e4ce58e6fa40da30 /lang/ruby_static
parentb41ae583e66cca53a8ce8586349d57dddbe87e00 (diff)
downloadports-99c64a19db42a1a7d016a3efed56a7649b2ba518.tar.gz
ports-99c64a19db42a1a7d016a3efed56a7649b2ba518.zip
Notes
Diffstat (limited to 'lang/ruby_static')
-rw-r--r--lang/ruby_static/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 3c1679702af1..be92b2620aae 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -19,7 +19,8 @@ USE_RUBY= yes
USE_AUTOCONF= yes
-# Beware, we can't statically link the gdbm module because gdbm is GPL'ed.
+# Beware, you can't statically link Ruby with GPL'ed libraries,
+# which means you can't link such modules as ruby-gdbm within.
EXT_PORTS= archivers/ruby-zlib \
devel/ruby-strscan \
sysutils/ruby-syslog
@@ -63,7 +64,7 @@ do-extract:
for x in *; do [ -d $$x ] && echo $$x >> Setup; done)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY}${_RUBY_SUFFIX}_s
- ${LN} -fs ${RUBY}${_RUBY_SUFFIX}_s ${RUBY}_s
+ ${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY_WITH_SUFFIX}_s
+ ${LN} -fs ${RUBY_WITH_SUFFIX}_s ${RUBY_WITHOUT_SUFFIX}_s
.include <bsd.port.post.mk>