aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-03-26 07:34:49 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-03-26 07:34:49 +0000
commit70918c2d7c33a6abda8c8841efd1f45bc73e5f66 (patch)
treecb4fb02a4091ffecfe0af558c249731d42cea578 /lang
parent0ff2e5f593cbc4158c3834a284461e194b38e3be (diff)
downloadports-70918c2d7c33a6abda8c8841efd1f45bc73e5f66.tar.gz
ports-70918c2d7c33a6abda8c8841efd1f45bc73e5f66.zip
lang/rust-bootstrap: Unbreak aarch64 bootstrap
Something goes wrong when it is built with LLVM > 9. Build it with llvm90 for the time being. rustc -Cllvm-args="..." with: Unknown command line argument '-generate-arange-section'. Try: 'rustc -Cllvm-args="..." with --help' rustc -Cllvm-args="..." with: Unknown command line argument '-mergefunc-use-aliases'. Try: 'rustc -Cllvm-args="..." with --help' rustc -Cllvm-args="..." with: Unknown command line argument '-preserve-alignment-assumptions-during-inlining=false'. Try: 'rustc -Cllvm-args="..." with --help' or when built with llvm.assertions=true: Assertion failed: (hasOptions() && "No options specified!"), function ParseCommandLineOptions, file src/llvm-project/llvm/lib/Support/CommandLine.cpp, line 1344.
Notes
Notes: svn path=/head/; revision=569245
Diffstat (limited to 'lang')
-rw-r--r--lang/rust-bootstrap/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index d28f413f2059..3ec780c9b8b6 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -5,7 +5,7 @@
# for the next lang/rust update.
PORTNAME= rust
PORTVERSION= 1.50.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:rust \
LOCAL/mikael:armbase \
@@ -39,6 +39,7 @@ FLAVORS= aarch64 amd64 armv6 armv7 i386 powerpc64_elfv1 powerpc64_elfv2 powerpc6
FLAVOR?= ${FLAVORS:[1]}
aarch64_PKGNAMEPREFIX= aarch64-
+aarch64_BUILD_DEPENDS= llvm90>0:devel/llvm90
amd64_PKGNAMEPREFIX= amd64-
armv6_PKGNAMEPREFIX= armv6-
armv7_PKGNAMEPREFIX= armv7-
@@ -54,6 +55,10 @@ USE_GCC= 9:build
.endif
# for openssl-src crate
USE_PERL5= build
+.if ${FLAVOR} == aarch64
+CC= clang90
+CXX= clang++90
+.endif
PATCHDIR= ${.CURDIR}/../rust/files
# Resulting packages are not specific to amd64
NO_ARCH= yes