aboutsummaryrefslogtreecommitdiff
path: root/mail/mu/Makefile
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2012-03-03 04:26:17 +0000
committerEygene Ryabinkin <rea@FreeBSD.org>2012-03-03 04:26:17 +0000
commit5ee41df74e99a32738d6f5b8843f289ae9bdd42f (patch)
treef319d54c124bed8d80c9b29dfa18c1dbced6852b /mail/mu/Makefile
parentfa3060ce8026a834a44d83db82f5510559f8462e (diff)
downloadports-5ee41df74e99a32738d6f5b8843f289ae9bdd42f.tar.gz
ports-5ee41df74e99a32738d6f5b8843f289ae9bdd42f.zip
New port: mail/mu
Mu is the mail indexer that uses Xapian as the search engine. In my tests it is blazingly fast, at least 5 times faster than nmzmail and it understands cyrillic ;)) QA page: http://codelabs.ru/fbsd/ports/qa/mail/mu/0.9.8.1
Notes
Notes: svn path=/head/; revision=292562
Diffstat (limited to 'mail/mu/Makefile')
-rw-r--r--mail/mu/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
new file mode 100644
index 000000000000..1dabd79ec2b6
--- /dev/null
+++ b/mail/mu/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: mu
+# Date created: 2 March 2012
+# Whom: rea@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mu
+PORTVERSION= 0.9.8.1
+CATEGORIES= mail
+MASTER_SITES= http://mu0.googlecode.com/files/
+
+MAINTAINER= rea@FreeBSD.org
+COMMENT= Mail searching frontend for Xapian
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core \
+ gmime:${PORTSDIR}/mail/gmime24
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 pkgconfig
+
+MAN1= mu-cfind.1 mu-easy.1 mu-extract.1 mu-find.1 mu-index.1 \
+ mu-mkdir.1 mu-view.1 mu-add.1 mu-remove.1 mu-server.1 mu.1 \
+ mug.1
+MAN5= mu-bookmarks.5
+
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-gui=none
+
+do-install:
+ cd ${WRKSRC}/src && ${INSTALL_PROGRAM} mu ${PREFIX}/bin
+ cd ${FILESDIR} && ${INSTALL_SCRIPT} mu-ask ${PREFIX}/bin
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN5} ${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>