aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-SPF
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2013-05-14 19:12:23 +0000
committerStefan Walter <stefan@FreeBSD.org>2013-05-14 19:12:23 +0000
commitc928408d608d21100e27336105f99305bbc46213 (patch)
tree594aea9aac47c3376e115f2ba0b0ba39e64127da /mail/p5-Mail-SPF
parent4950b4305b8213052dfb4972c102ac55506928f5 (diff)
downloadports-c928408d608d21100e27336105f99305bbc46213.tar.gz
ports-c928408d608d21100e27336105f99305bbc46213.zip
Notes
Diffstat (limited to 'mail/p5-Mail-SPF')
-rw-r--r--mail/p5-Mail-SPF/Makefile34
-rw-r--r--mail/p5-Mail-SPF/files/extra-patch-no-spfquery33
-rw-r--r--mail/p5-Mail-SPF/files/extra-patch-spfquery-suffix35
-rw-r--r--mail/p5-Mail-SPF/pkg-descr2
-rw-r--r--mail/p5-Mail-SPF/pkg-plist2
5 files changed, 99 insertions, 7 deletions
diff --git a/mail/p5-Mail-SPF/Makefile b/mail/p5-Mail-SPF/Makefile
index 47d16f6626a8..62d296514c32 100644
--- a/mail/p5-Mail-SPF/Makefile
+++ b/mail/p5-Mail-SPF/Makefile
@@ -3,13 +3,13 @@
PORTNAME= Mail-SPF
PORTVERSION= 2.007
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-v${PORTVERSION}
-MAINTAINER= gmc@sonologic.nl
+MAINTAINER= ports@FreeBSD.org
COMMENT= Reference implementation of the RFC 4408 SPF protocol
RUN_DEPENDS= p5-Net-DNS-Resolver-Programmable>=0.002.1:${PORTSDIR}/dns/p5-Net-DNS-Resolver-Programmable \
@@ -20,12 +20,11 @@ RUN_DEPENDS= p5-Net-DNS-Resolver-Programmable>=0.002.1:${PORTSDIR}/dns/p5-Net-DN
p5-URI>=1.13:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-CONFLICTS= libspf2-[0-9]* p5-Mail-SPF-Query-[0-9]*
+CONFLICTS= p5-Mail-SPF-Query-[0-9]*
PERL_MODBUILD= yes
CONFIGURE_ARGS= --install_path sbin=${PREFIX}/sbin
-MAN1= spfquery.1
MAN3= Mail::SPF.3 Mail::SPF::Mech::PTR.3 Mail::SPF::Mech.3 \
Mail::SPF::SenderIPAddrMech.3 Mail::SPF::MacroString.3 \
Mail::SPF::Mech::IP4.3 Mail::SPF::Mech::A.3 \
@@ -37,13 +36,38 @@ MAN3= Mail::SPF.3 Mail::SPF::Mech::PTR.3 Mail::SPF::Mech.3 \
Mail::SPF::Base.3 Mail::SPF::Mech::All.3 Mail::SPF::Term.3 \
Mail::SPF::v1::Record.3 Mail::SPF::Mech::Exists.3
+OPTIONS_DEFINE= SPFQUERY SPFQUERY_SUFFIX DOCS
+SPFQUERY_DESC= Install spfquery command-line tool
+SPFQUERY_SUFFIX_DESC=Add .pl suffix to spfquery
+OPTIONS_DEFAULT=SPFQUERY SPFQUERY_SUFFIX
+
.include <bsd.port.pre.mk>
DOCSDIR= ${PREFIX}/share/doc/p5-Mail-SPF
DOCS= CHANGES INSTALL LICENSE README TODO
+.if ${PORT_OPTIONS:MSPFQUERY}
+PLIST_SUB+= SPFQUERY=""
+
+.if ${PORT_OPTIONS:MSPFQUERY_SUFFIX}
+PLIST_SUB+= SPFQUERY_SUFFIX=".pl"
+MAN1+= spfquery.pl.1
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-spfquery-suffix
+post-extract:
+ ${MV} ${WRKSRC}/bin/spfquery ${WRKSRC}/bin/spfquery.pl
+.else
+PLIST_SUB+= SPFQUERY_SUFFIX=""
+MAN1+= spfquery.1
+CONFLICTS+= libspf2-[0-9]*
+.endif
+
+.else
+PLIST_SUB+= SPFQUERY="@comment "
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-no-spfquery
+.endif
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
diff --git a/mail/p5-Mail-SPF/files/extra-patch-no-spfquery b/mail/p5-Mail-SPF/files/extra-patch-no-spfquery
new file mode 100644
index 000000000000..e2abc6438f44
--- /dev/null
+++ b/mail/p5-Mail-SPF/files/extra-patch-no-spfquery
@@ -0,0 +1,33 @@
+diff -Naur orig/Build.PL Build.PL
+--- orig/Build.PL 2009-10-31 23:16:14.000000000 +0100
++++ Build.PL 2011-05-24 19:27:19.000000000 +0200
+@@ -66,7 +66,6 @@
+ => 'v0.002.1',
+ },
+ script_files => [
+- 'bin/spfquery'
+ ],
+ install_path => {
+ 'sbin' => '/usr/sbin'
+diff -Naur orig/MANIFEST MANIFEST
+--- orig/MANIFEST 2009-10-31 23:16:14.000000000 +0100
++++ MANIFEST 2011-05-24 19:26:56.000000000 +0200
+@@ -1,4 +1,3 @@
+-bin/spfquery
+ Build.PL
+ CHANGES
+ debian/changelog
+diff -Naur orig/README README
+--- orig/README 2009-10-31 23:16:14.000000000 +0100
++++ README 2011-05-24 19:27:05.000000000 +0200
+@@ -12,9 +12,8 @@
+ This release of Mail::SPF fully conforms to RFC 4408 and passes the 2008.08
+ release of the official test-suite <http://www.openspf.org/Test_Suite>.
+
+-The Mail::SPF source package includes the following additional tools:
++The Mail::SPF source package includes the following additional tool:
+
+- * spfquery: A command-line tool for performing SPF checks.
+ * spfd: A daemon for services that perform SPF checks frequently.
+
+ Mail::SPF is not your mother!
diff --git a/mail/p5-Mail-SPF/files/extra-patch-spfquery-suffix b/mail/p5-Mail-SPF/files/extra-patch-spfquery-suffix
new file mode 100644
index 000000000000..1355b738b101
--- /dev/null
+++ b/mail/p5-Mail-SPF/files/extra-patch-spfquery-suffix
@@ -0,0 +1,35 @@
+diff -Naur orig/Build.PL Build.PL
+--- orig/Build.PL 2009-10-31 23:16:14.000000000 +0100
++++ Build.PL 2011-05-24 19:40:10.000000000 +0200
+@@ -66,7 +66,7 @@
+ => 'v0.002.1',
+ },
+ script_files => [
+- 'bin/spfquery'
++ 'bin/spfquery.pl'
+ ],
+ install_path => {
+ 'sbin' => '/usr/sbin'
+diff -Naur orig/MANIFEST MANIFEST
+--- orig/MANIFEST 2009-10-31 23:16:14.000000000 +0100
++++ MANIFEST 2011-05-24 19:40:36.000000000 +0200
+@@ -1,4 +1,4 @@
+-bin/spfquery
++bin/spfquery.pl
+ Build.PL
+ CHANGES
+ debian/changelog
+diff -Naur orig/README README
+--- orig/README 2009-10-31 23:16:14.000000000 +0100
++++ README 2011-05-24 19:40:54.000000000 +0200
+@@ -14,8 +14,8 @@
+
+ The Mail::SPF source package includes the following additional tools:
+
+- * spfquery: A command-line tool for performing SPF checks.
+- * spfd: A daemon for services that perform SPF checks frequently.
++ * spfquery.pl: A command-line tool for performing SPF checks.
++ * spfd: A daemon for services that perform SPF checks frequently.
+
+ Mail::SPF is not your mother!
+ -----------------------------
diff --git a/mail/p5-Mail-SPF/pkg-descr b/mail/p5-Mail-SPF/pkg-descr
index b4f312325bd0..02dea499933b 100644
--- a/mail/p5-Mail-SPF/pkg-descr
+++ b/mail/p5-Mail-SPF/pkg-descr
@@ -9,4 +9,4 @@ The Mail::SPF source package includes the following additional tools:
* spfquery: A command-line tool for performing SPF checks.
* spfd: A daemon for services that perform SPF checks frequently.
-WWW: http://www.openspf.org/
+WWW: http://www.openspf.org/
diff --git a/mail/p5-Mail-SPF/pkg-plist b/mail/p5-Mail-SPF/pkg-plist
index e9e86ada2c2e..0f4a436f01d8 100644
--- a/mail/p5-Mail-SPF/pkg-plist
+++ b/mail/p5-Mail-SPF/pkg-plist
@@ -1,4 +1,4 @@
-bin/spfquery
+%%SPFQUERY%%bin/spfquery%%SPFQUERY_SUFFIX%%
sbin/spfd
%%SITE_PERL%%/Mail/SPF.pm
%%SITE_PERL%%/Mail/SPF/MacroString.pm