aboutsummaryrefslogtreecommitdiff
path: root/mail/pop3vscan
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-07 16:40:54 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-07 16:40:54 +0000
commit23a4d970cb2313b584b0ada3f382e5e454b11651 (patch)
treea8fbffb936d84e97d85057e575841a1309cfe66e /mail/pop3vscan
parent9ad2b45ab89dd301c91a47ce2930ce33ac583d10 (diff)
downloadports-23a4d970cb2313b584b0ada3f382e5e454b11651.tar.gz
ports-23a4d970cb2313b584b0ada3f382e5e454b11651.zip
Notes
Diffstat (limited to 'mail/pop3vscan')
-rw-r--r--mail/pop3vscan/Makefile5
-rw-r--r--mail/pop3vscan/distinfo1
-rw-r--r--mail/pop3vscan/pkg-install4
3 files changed, 6 insertions, 4 deletions
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
index dce6607ba0ee..0011eb6a8545 100644
--- a/mail/pop3vscan/Makefile
+++ b/mail/pop3vscan/Makefile
@@ -18,13 +18,14 @@ COMMENT= A transparent POP3-Proxy with virus-scanning capabilities
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
.if !defined(WITHOUT_UVSCAN)
-RUN_DEPENDS= uvscan:${PORTSDIR}/security/vscan
+RUN_DEPENDS+= uvscan:${PORTSDIR}/security/vscan
.endif
USE_REINPLACE= yes
USE_GMAKE= yes
USE_GETOPT_LONG=yes
MAKE_ENV= _LDFLAGS="${LDFLAGS}"
+SCRIPTS_ENV= PKG_PREFIX=${PREFIX} NONEXISTENT=${NONEXISTENT} PASSWD=/etc/passwd
pre-fetch:
.if !defined(WITHOUT_UVSCAN)
@@ -50,7 +51,7 @@ do-install:
${INSTALL_SCRIPT} ${FILESDIR}/pop3vscan.sh ${PREFIX}/etc/rc.d/
post-install:
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${SED} -e 's,PREFIX,${PREFIX},g' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/pop3vscan/distinfo b/mail/pop3vscan/distinfo
index 49a176f2c9b8..bac2c4d4f8be 100644
--- a/mail/pop3vscan/distinfo
+++ b/mail/pop3vscan/distinfo
@@ -1 +1,2 @@
MD5 (pop3vscan-0.4.tar.gz) = 48783c81cf70590637993aa0082fa467
+SIZE (pop3vscan-0.4.tar.gz) = 134583
diff --git a/mail/pop3vscan/pkg-install b/mail/pop3vscan/pkg-install
index b478c2a8b668..696771306193 100644
--- a/mail/pop3vscan/pkg-install
+++ b/mail/pop3vscan/pkg-install
@@ -48,7 +48,7 @@ make_account() {
echo "Done."
else
echo "Please create it, and try again."
- if ! grep -q "^${u}:" /etc/passwd; then
+ if ! grep -q "^${u}:" ${PASSWD}; then
echo "While you're at it, please create a user \"${u}\" too,"
echo "with a default group of \"${g}\"."
fi
@@ -62,7 +62,7 @@ make_account() {
echo "You need a user \"${u}\"."
if which -s pw && yesno "Would you like me to create it" y; then
pw useradd ${u} -g ${g} -h - ${homeopt} \
- -s /nonexistent -c "${gcos}" || exit
+ -s ${NONEXISTENT} -c "${gcos}" || exit
echo "Done."
else
echo "Please create it, and try again."