aboutsummaryrefslogtreecommitdiff
path: root/mail/py-django-mailbox
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-04-15 13:52:08 +0000
committerDan Langille <dvl@FreeBSD.org>2021-04-15 13:55:12 +0000
commit3d883faa9f453a30710473c75231f64ed6a9942b (patch)
tree2cb34e51d77d9ca70ffd146721091cf98265bc39 /mail/py-django-mailbox
parent4ec0339f7320234aa2a0739ddb7b6b04598b9226 (diff)
downloadports-3d883faa9f453a30710473c75231f64ed6a9942b.tar.gz
ports-3d883faa9f453a30710473c75231f64ed6a9942b.zip
Diffstat (limited to 'mail/py-django-mailbox')
-rw-r--r--mail/py-django-mailbox/Makefile20
-rw-r--r--mail/py-django-mailbox/distinfo3
-rw-r--r--mail/py-django-mailbox/pkg-descr9
3 files changed, 32 insertions, 0 deletions
diff --git a/mail/py-django-mailbox/Makefile b/mail/py-django-mailbox/Makefile
new file mode 100644
index 000000000000..78b8dc6cd689
--- /dev/null
+++ b/mail/py-django-mailbox/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= django-mailbox
+PORTVERSION= 4.8.2
+CATEGORIES= mail
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gettoknowmi@yahoo.com
+COMMENT= Easily ingest messages from POP3, IMAP, or local mailboxes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.4+,run
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/py-django-mailbox/distinfo b/mail/py-django-mailbox/distinfo
new file mode 100644
index 000000000000..c556bb39a4f7
--- /dev/null
+++ b/mail/py-django-mailbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617293873
+SHA256 (django-mailbox-4.8.2.tar.gz) = c5e00ab266593f5e27486eaa45f97b367d0bd57b5105dcb8c97a5cb6008c9cde
+SIZE (django-mailbox-4.8.2.tar.gz) = 2976691
diff --git a/mail/py-django-mailbox/pkg-descr b/mail/py-django-mailbox/pkg-descr
new file mode 100644
index 000000000000..a24ea8d8b625
--- /dev/null
+++ b/mail/py-django-mailbox/pkg-descr
@@ -0,0 +1,9 @@
+Easily ingest messages from POP3, IMAP, or local mailboxes
+into your Django application.
+
+This app allows you to either ingest e-mail content from common e-mail services
+(as long as the service provides POP3 or IMAP support), or directly receive
+e-mail messages from stdin (for locally processing messages
+from Postfix or Exim4).
+
+WWW: https://github.com/coddingtonbear/django-mailbox/