aboutsummaryrefslogtreecommitdiff
path: root/mail/thunderbird3
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-01-18 22:37:11 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-01-18 22:37:11 +0000
commitfaa1047dd911a3de51604e2abc47ea61fab2345a (patch)
tree6c3a5ab8efb06f80a334dfa4ebfefe5497a12792 /mail/thunderbird3
parentcf7f380693c143bba74cb65cb11bc5099b76e4ec (diff)
downloadports-faa1047dd911a3de51604e2abc47ea61fab2345a.tar.gz
ports-faa1047dd911a3de51604e2abc47ea61fab2345a.zip
Notes
Diffstat (limited to 'mail/thunderbird3')
-rw-r--r--mail/thunderbird3/Makefile1
-rw-r--r--mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp18
2 files changed, 19 insertions, 0 deletions
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 87999415623c..acd11e267ec5 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 1.5.0.9
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp b/mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/mail/thunderbird3/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void