aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 14:41:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 14:41:56 +0000
commit70857128b218e2cbf5a24253b8c41dc7eae5864a (patch)
tree0c246ff098cb5f663a8b031cf416456b0e089b2c /mail
parent4242259086f83c81ee2da8e6cd53a3a5498b1faa (diff)
downloadports-70857128b218e2cbf5a24253b8c41dc7eae5864a.tar.gz
ports-70857128b218e2cbf5a24253b8c41dc7eae5864a.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-fetchinfo/Makefile33
-rw-r--r--mail/claws-mail-fetchinfo/distinfo3
-rw-r--r--mail/claws-mail-fetchinfo/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-fetchinfo/pkg-descr2
-rw-r--r--mail/sylpheed-claws-fetchinfo/Makefile33
-rw-r--r--mail/sylpheed-claws-fetchinfo/distinfo3
-rw-r--r--mail/sylpheed-claws-fetchinfo/files/patch-configure.ac15
-rw-r--r--mail/sylpheed-claws-fetchinfo/pkg-descr2
9 files changed, 107 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 122b94ebbdc1..4731e3837ff6 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -523,6 +523,7 @@
SUBDIR += swaks
SUBDIR += sylpheed
SUBDIR += sylpheed-claws
+ SUBDIR += sylpheed-claws-fetchinfo
SUBDIR += sylpheed-claws-mailmbox
SUBDIR += sylpheed-claws-perl
SUBDIR += sylpheed-claws-smime
diff --git a/mail/claws-mail-fetchinfo/Makefile b/mail/claws-mail-fetchinfo/Makefile
new file mode 100644
index 000000000000..75bf4b11f88e
--- /dev/null
+++ b/mail/claws-mail-fetchinfo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sylpheed-claws-fetchinfo
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fetchinfo
+PORTVERSION= 0.4.12
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+DISTNAME= ${PORTNAME}-plugin-${PORTVERSION}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Header insertation plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES= lib/sylpheed-claws/plugins/fetchinfo_plugin.a \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin.la \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin.so \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.a \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.la \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.so \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.deps
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-fetchinfo/distinfo b/mail/claws-mail-fetchinfo/distinfo
new file mode 100644
index 000000000000..4c141c993609
--- /dev/null
+++ b/mail/claws-mail-fetchinfo/distinfo
@@ -0,0 +1,3 @@
+MD5 (fetchinfo-plugin-0.4.12.tar.gz) = 009f5784b1fb5961ea21889acfe3c81b
+SHA256 (fetchinfo-plugin-0.4.12.tar.gz) = a1ea1d4d178372e5be24322fdee0cb6e8ff6d0a50e44ed2398192c3113df73df
+SIZE (fetchinfo-plugin-0.4.12.tar.gz) = 322311
diff --git a/mail/claws-mail-fetchinfo/files/patch-configure.ac b/mail/claws-mail-fetchinfo/files/patch-configure.ac
new file mode 100644
index 000000000000..517142f72848
--- /dev/null
+++ b/mail/claws-mail-fetchinfo/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:20:30 2006
++++ configure.ac Wed Apr 5 20:21:26 2006
+@@ -28,7 +28,11 @@
+ # Check for sylpheed-claws
+ #
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/claws-mail-fetchinfo/pkg-descr b/mail/claws-mail-fetchinfo/pkg-descr
new file mode 100644
index 000000000000..96ec1785f6dd
--- /dev/null
+++ b/mail/claws-mail-fetchinfo/pkg-descr
@@ -0,0 +1,2 @@
+This plugin inserts headers containing some download information: UIDL,
+Sylpheeds account name, POP server, user ID and retrieval time.
diff --git a/mail/sylpheed-claws-fetchinfo/Makefile b/mail/sylpheed-claws-fetchinfo/Makefile
new file mode 100644
index 000000000000..75bf4b11f88e
--- /dev/null
+++ b/mail/sylpheed-claws-fetchinfo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sylpheed-claws-fetchinfo
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fetchinfo
+PORTVERSION= 0.4.12
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+DISTNAME= ${PORTNAME}-plugin-${PORTVERSION}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Header insertation plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES= lib/sylpheed-claws/plugins/fetchinfo_plugin.a \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin.la \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin.so \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.a \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.la \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.so \
+ lib/sylpheed-claws/plugins/fetchinfo_plugin_gtk.deps
+
+.include <bsd.port.mk>
diff --git a/mail/sylpheed-claws-fetchinfo/distinfo b/mail/sylpheed-claws-fetchinfo/distinfo
new file mode 100644
index 000000000000..4c141c993609
--- /dev/null
+++ b/mail/sylpheed-claws-fetchinfo/distinfo
@@ -0,0 +1,3 @@
+MD5 (fetchinfo-plugin-0.4.12.tar.gz) = 009f5784b1fb5961ea21889acfe3c81b
+SHA256 (fetchinfo-plugin-0.4.12.tar.gz) = a1ea1d4d178372e5be24322fdee0cb6e8ff6d0a50e44ed2398192c3113df73df
+SIZE (fetchinfo-plugin-0.4.12.tar.gz) = 322311
diff --git a/mail/sylpheed-claws-fetchinfo/files/patch-configure.ac b/mail/sylpheed-claws-fetchinfo/files/patch-configure.ac
new file mode 100644
index 000000000000..517142f72848
--- /dev/null
+++ b/mail/sylpheed-claws-fetchinfo/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:20:30 2006
++++ configure.ac Wed Apr 5 20:21:26 2006
+@@ -28,7 +28,11 @@
+ # Check for sylpheed-claws
+ #
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/sylpheed-claws-fetchinfo/pkg-descr b/mail/sylpheed-claws-fetchinfo/pkg-descr
new file mode 100644
index 000000000000..96ec1785f6dd
--- /dev/null
+++ b/mail/sylpheed-claws-fetchinfo/pkg-descr
@@ -0,0 +1,2 @@
+This plugin inserts headers containing some download information: UIDL,
+Sylpheeds account name, POP server, user ID and retrieval time.