aboutsummaryrefslogtreecommitdiff
path: root/math/clrng
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-17 18:07:25 +0000
commit05360ec71eab4f178074bd97c1373e7659a59bbb (patch)
treea430ad3dbd823ddb88d16ecc11a7a7035985cf79 /math/clrng
parent7bc4660db0fb55cc34f11c9263904d676fc7445b (diff)
downloadports-05360ec71eab4f178074bd97c1373e7659a59bbb.tar.gz
ports-05360ec71eab4f178074bd97c1373e7659a59bbb.zip
Update Mesa port to 10.6.6 and add Clover.
Add beignet 1.1.0. Add clinfo, clblas, clfft and clrng. The major change is that all Mesa ports are now configured the same way. This fixes several problems and enables new features. The details are described in this blog post: http://blogs.freebsdish.org/graphics/2015/03/18/unifying-mesa-ports-configure/ The second important change is the OpenCL support. Mesa's implementation, Clover, is enabled as well as Beignet. Clover targets all Gallium drivers, only Radeon GPUs in our case. Beignet is for Intel GPUs starting with Ivy Bridge. Thanks to Johannes Dieterich, O. Hartman, and Koop Mast for their work on OpenCL! As a bonus, there are several OpenCL-based math ports added (clblas, clfft and clrng). For more information and known issues, please see https://wiki.freebsd.org/Graphics/OpenCL The third change is the removal of Mesa 9.1.7 which was installed on FreeBSD 9.3-RELEASE. There is now only one version of Mesa in the Ports tree (10.6.6) for all supported versions of FreeBSD. Other, smaller changes: * Include libosmesa into the Mesa framework; this changes libOSMesa shlib version. * bsd.mesalib.mk was renamed and split up in two files namely Makefile.common and Makefile.targets. So ports can overwrite variables set by Makefile.common and are used by Makefile.targets. * Some text in the pkg-descr files was wrong, clean it up. While here, update the WWW to the main mesa3d.org upstream page. * devel/clinfo was added, a glxinfo like program but for OpenCL. Non-x86 hardware reports are very welcome since we changed the framework quite a bit. Obtained from: Graphics team development repo.
Notes
Notes: svn path=/head/; revision=397198
Diffstat (limited to 'math/clrng')
-rw-r--r--math/clrng/Makefile35
-rw-r--r--math/clrng/distinfo2
-rw-r--r--math/clrng/pkg-descr13
-rw-r--r--math/clrng/pkg-plist28
4 files changed, 78 insertions, 0 deletions
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
new file mode 100644
index 000000000000..b98155379469
--- /dev/null
+++ b/math/clrng/Makefile
@@ -0,0 +1,35 @@
+# Created by: Johannes Dieterich <dieterich@ogolem.org>
+# $FreeBSD$
+
+PORTNAME= clrng
+DISTVERSION= 1.0.0-beta
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= dieterich@ogolem.org
+COMMENT= Software library containing BLAS functions written in OpenCL
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
+RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
+
+ONLY_FOR_ARCHS= amd64
+
+USE_GITHUB= yes
+GH_ACCOUNT= clMathLibraries
+GH_PROJECT= clRNG
+
+USE_LDCONFIG= yes
+USES= cmake
+
+CMAKE_ARGS+= -DBUILD_CLIENT=OFF \
+ -DBUILD_TEST=OFF \
+ -DSUFFIX_LIB="" \
+ -DSUFFIX_BIN=""
+
+CMAKE_SOURCE_PATH= ${WRKSRC}/src
+
+.include <bsd.port.mk>
diff --git a/math/clrng/distinfo b/math/clrng/distinfo
new file mode 100644
index 000000000000..3e71629ccc21
--- /dev/null
+++ b/math/clrng/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clMathLibraries-clRNG-v1.0.0-beta_GH0.tar.gz) = 12e46c89a577ea26ea8af2b11176b1c503c2b0a28a3766178f317f21f27324f4
+SIZE (clMathLibraries-clRNG-v1.0.0-beta_GH0.tar.gz) = 127591
diff --git a/math/clrng/pkg-descr b/math/clrng/pkg-descr
new file mode 100644
index 000000000000..288caa3c9ce9
--- /dev/null
+++ b/math/clrng/pkg-descr
@@ -0,0 +1,13 @@
+clRNG
+
+a library for uniform random number generation in OpenCL.
+
+Streams of random numbers act as virtual random number generators.
+They can be created on the host computer in unlimited numbers, and
+then used either on the host or on computing devices by work items
+to generate random numbers. Each stream also has equally-spaced
+substreams, which are occasionally useful. The API is currently
+implemented for four different RNGs, namely the MRG31k3p, MRG32k3a,
+LFSR113 and Philox-4x32-10 generators.
+
+WWW: https://github.com/clMathLibraries/clRNG
diff --git a/math/clrng/pkg-plist b/math/clrng/pkg-plist
new file mode 100644
index 000000000000..723550bab68d
--- /dev/null
+++ b/math/clrng/pkg-plist
@@ -0,0 +1,28 @@
+cl/include/clRNG.clh
+cl/include/lfsr113.clh
+cl/include/mrg31k3p.clh
+cl/include/mrg32k3a.clh
+cl/include/philox432.clh
+cl/include/private/Random123/array.h
+cl/include/private/Random123/features/clangfeatures.h
+cl/include/private/Random123/features/compilerfeatures.h
+cl/include/private/Random123/features/gccfeatures.h
+cl/include/private/Random123/features/msvcfeatures.h
+cl/include/private/Random123/features/open64features.h
+cl/include/private/Random123/features/openclfeatures.h
+cl/include/private/Random123/features/sse.h
+cl/include/private/Random123/philox.h
+cl/include/private/lfsr113.c.h
+cl/include/private/modular.c.h
+cl/include/private/mrg31k3p.c.h
+cl/include/private/mrg32k3a.c.h
+cl/include/private/philox432.c.h
+include/clRNG.h
+include/clRNG.version.h
+include/lfsr113.h
+include/mrg31k3p.h
+include/mrg32k3a.h
+include/philox432.h
+lib/libclRNG.so
+lib/libclRNG.so.1
+lib/libclRNG.so.1.0.0