aboutsummaryrefslogtreecommitdiff
path: root/math/half/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-26 21:32:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-26 21:32:58 +0000
commitaf24a3a1a4bac34e96d625f1eb27b091d7b82960 (patch)
tree301bb4546d50790556e6aa1555e225427a2a9ec5 /math/half/Makefile
parent6e4c5541efa0d6904b8403038267d0f82ece4930 (diff)
downloadports-af24a3a1a4bac34e96d625f1eb27b091d7b82960.tar.gz
ports-af24a3a1a4bac34e96d625f1eb27b091d7b82960.zip
Notes
Diffstat (limited to 'math/half/Makefile')
-rw-r--r--math/half/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/half/Makefile b/math/half/Makefile
new file mode 100644
index 000000000000..998e9ae8e66e
--- /dev/null
+++ b/math/half/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= half
+DISTVERSION= 2.1.0
+CATEGORIES= math
+MASTER_SITES= SF
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ library for half precision floating point arithmetic
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= zip
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/half.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/include/half.hpp ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>