aboutsummaryrefslogtreecommitdiff
path: root/math/libqalculate
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-26 11:22:36 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-26 11:22:36 +0000
commitff9dc9b22b5e05527cf3341a1e0f9fffa8ef550b (patch)
tree5482c3a59fe2095b80026f1854bfa7dae1ec1d0f /math/libqalculate
parent31d1cf70b46097603968a75a3cbd689f4caa287c (diff)
downloadports-ff9dc9b22b5e05527cf3341a1e0f9fffa8ef550b.tar.gz
ports-ff9dc9b22b5e05527cf3341a1e0f9fffa8ef550b.zip
math/libqalculate: Update to 2.2.1
math/qalculate: Update to 2.2.1 Download the pre-rolled releases hosted on GitHub instead of using USE_GITHUB to avoid running autoreconf, etc. Backport upsteam patches for several instances of FindQalculate.cmake in KDE 4.x ports that could not detect the newer libqalculate. Bump PORTREVISION on dependent ports due to shared library version increase. Changes: https://qalculate.github.io/news.html Differential Revision: https://reviews.freebsd.org/D14459
Notes
Notes: svn path=/head/; revision=463014
Diffstat (limited to 'math/libqalculate')
-rw-r--r--math/libqalculate/Makefile21
-rw-r--r--math/libqalculate/distinfo6
-rw-r--r--math/libqalculate/files/patch-git_issue3868
-rw-r--r--math/libqalculate/files/patch-libqalculate.pc.in13
-rw-r--r--math/libqalculate/pkg-plist6
5 files changed, 18 insertions, 96 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 4451d23a3dd9..8dd81c0af853 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= libqalculate
-DISTVERSION= 1.0.0a
-DISTVERSIONPREFIX= v
+PORTVERSION= 2.2.1
CATEGORIES= math
+MASTER_SITES= https://github.com/Qalculate/${PORTNAME}/releases/download/v${PORTVERSION}/
MAINTAINER= jhale@FreeBSD.org
COMMENT= Multi-purpose desktop calculator (backend library)
@@ -12,25 +12,26 @@ COMMENT= Multi-purpose desktop calculator (backend library)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcln.so:math/cln
+LIB_DEPENDS= libicuuc.so:devel/icu \
+ libcurl.so:ftp/curl \
+ libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr
-USES= autoreconf gmake gettext libtool localbase \
+USES= gmake gettext iconv libtool localbase \
ncurses pathfix pkgconfig readline:port
-USE_GNOME= glib20 intltool libxml2
+USE_GNOME= intltool libxml2
USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_GITHUB= yes
-GH_ACCOUNT= Qalculate
-
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
post-patch-NLS-off:
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.in
post-patch:
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/math/libqalculate/distinfo b/math/libqalculate/distinfo
index 75f1877f0bf8..285a393ef63f 100644
--- a/math/libqalculate/distinfo
+++ b/math/libqalculate/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501594307
-SHA256 (Qalculate-libqalculate-v1.0.0a_GH0.tar.gz) = 3d9e9e983cf1bfded8063e4704587d42e2253cbfc5d60a9ecefc1b9b43ab2f8a
-SIZE (Qalculate-libqalculate-v1.0.0a_GH0.tar.gz) = 599217
+TIMESTAMP = 1518998683
+SHA256 (libqalculate-2.2.1.tar.gz) = 1752b6a046eaf84ee62a7dc8d2c874b538517956ce8affac80df09a3b55bef5d
+SIZE (libqalculate-2.2.1.tar.gz) = 1717947
diff --git a/math/libqalculate/files/patch-git_issue38 b/math/libqalculate/files/patch-git_issue38
deleted file mode 100644
index 9cf369b54dd5..000000000000
--- a/math/libqalculate/files/patch-git_issue38
+++ /dev/null
@@ -1,68 +0,0 @@
-Prevent qalc from segfaulting if started and immediately exited.
-See: https://github.com/Qalculate/libqalculate/issues/38
-
-diff --git a/libqalculate/Calculator.cc b/libqalculate/Calculator.cc
-index f5c183f..4963351 100644
---- libqalculate/Calculator.cc.orig
-+++ libqalculate/Calculator.cc
-@@ -224,8 +226,11 @@ void autoConvert(const MathStructure &morig, MathStructure &mconv, const Evaluat
- void CalculateThread::run() {
- enableAsynchronousCancel();
- while(true) {
-- bool b_parse = read<bool>();
-- void *x = read<void *>();
-+ bool failed = false;
-+ bool b_parse = read<bool>(&failed);
-+ if(failed) break;
-+ void *x = read<void *>(&failed);
-+ if(failed) break;
- MathStructure *mstruct = (MathStructure*) x;
- CALCULATOR->startControl();
- if(b_parse) {
-diff --git a/libqalculate/util.h b/libqalculate/util.h
-index 0edcb50..533f5c7 100644
---- libqalculate/util.h.orig
-+++ libqalculate/util.h
-@@ -128,14 +128,16 @@ public:
- protected:
- virtual void run() = 0;
- void enableAsynchronousCancel();
-- template <class T> T read() {
-+ template <class T> T read(bool *failed = NULL) {
- #ifdef _WIN32
- MSG msg;
- int ret = GetMessage(&msg, NULL, WM_USER, WM_USER);
-+ if(failed && (ret == 0 || ret == -1)) *failed = true;
- return (T) msg.wParam;
- #else
- T x;
-- fread(&x, sizeof(T), 1, m_pipe_r);
-+ int ret = fread(&x, sizeof(T), 1, m_pipe_r);
-+ if(failed && ret != 1) *failed = true;
- return x;
- #endif
- }
-diff --git a/src/qalc.cc b/src/qalc.cc
-index 4a4e4b2..43c3556 100644
---- src/qalc.cc.orig
-+++ src/qalc.cc
-@@ -2821,12 +2821,15 @@ void on_abort_display() {
-
- void ViewThread::run() {
- while(true) {
--
-- void *x = read<void *>();
-+
-+ bool failed = false;
-+ void *x = read<void *>(&failed);
-+ if(failed) break;
- MathStructure m(*((MathStructure*) x));
- //bool b_stack = read<bool>();
-- read<bool>();
-- x = read<void *>();
-+ read<bool>(&failed);
-+ x = read<void *>(&failed);
-+ if(failed) break;
- CALCULATOR->startControl();
- if(x) {
- PrintOptions po;
diff --git a/math/libqalculate/files/patch-libqalculate.pc.in b/math/libqalculate/files/patch-libqalculate.pc.in
deleted file mode 100644
index d62088e09d4d..000000000000
--- a/math/libqalculate/files/patch-libqalculate.pc.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- libqalculate.pc.in.orig 2016-08-25 18:49:39 UTC
-+++ libqalculate.pc.in
-@@ -5,7 +5,7 @@ includedir=@includedir@
-
- Name: libqalculate
- Description: libqalculate
--Requires: glib-2.0 libxml-2.0
-+Requires: cln glib-2.0 libxml-2.0
- Version: @VERSION@
- Libs: -L${libdir} -lqalculate
--Cflags: -I${includedir}
-\ No newline at end of file
-+Cflags: -I${includedir}
diff --git a/math/libqalculate/pkg-plist b/math/libqalculate/pkg-plist
index ae77d17be4f7..884d2a11f8af 100644
--- a/math/libqalculate/pkg-plist
+++ b/math/libqalculate/pkg-plist
@@ -14,8 +14,8 @@ include/libqalculate/qalculate.h
include/libqalculate/util.h
lib/libqalculate.a
lib/libqalculate.so
-lib/libqalculate.so.10
-lib/libqalculate.so.10.0.0
+lib/libqalculate.so.14
+lib/libqalculate.so.14.0.0
libdata/pkgconfig/libqalculate.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libqalculate.mo
%%NLS%%share/locale/nl/LC_MESSAGES/libqalculate.mo
@@ -24,8 +24,10 @@ libdata/pkgconfig/libqalculate.pc
share/qalculate/currencies.xml
share/qalculate/datasets.xml
share/qalculate/elements.xml
+share/qalculate/eurofxref-daily.xml
share/qalculate/functions.xml
share/qalculate/planets.xml
share/qalculate/prefixes.xml
+share/qalculate/rates.json
share/qalculate/units.xml
share/qalculate/variables.xml