aboutsummaryrefslogtreecommitdiff
path: root/math/ogdf/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-09-06 07:31:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-09-06 07:31:12 +0000
commit3764d29dad49077a47477258d5200a92976bd877 (patch)
treee388d3e1efc2e03d5931c06a9ad0954633342fe2 /math/ogdf/Makefile
parent7577b4b8e2c5d47b50204d03f8eebef7f5b112ca (diff)
downloadports-3764d29dad49077a47477258d5200a92976bd877.tar.gz
ports-3764d29dad49077a47477258d5200a92976bd877.zip
Notes
Diffstat (limited to 'math/ogdf/Makefile')
-rw-r--r--math/ogdf/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/math/ogdf/Makefile b/math/ogdf/Makefile
new file mode 100644
index 000000000000..738da6c387c7
--- /dev/null
+++ b/math/ogdf/Makefile
@@ -0,0 +1,61 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= ogdf
+PORTVERSION= 2012.07
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~gahr/distfiles/
+MASTER_SITE_SUBDIR= gahr
+DISTNAME= ogdf.v2012.07
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= C++ class library for the automatic layout of diagrams
+
+OPTIONS_DEFINE= COIN ABACUS
+COIN_DESC= Use the Coin Open Solver Interface (Osi)
+ABACUS_DESC= Use the ABACUS branch-and-cut library
+
+LICENSE= GPLv2
+
+USE_ZIP= yes
+USE_LDCONFIG= yes
+USE_PYTHON= build
+
+WRKSRC= ${WRKDIR}/${PORTNAME:U}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCOIN}
+LIB_DEPENDS+= Clp:${PORTSDIR}/math/coinmp
+USE_COIN= true
+.else
+USE_COIN= false
+.endif
+
+.if ${PORT_OPTIONS:MABACUS}
+USE_GCC= 4.4+
+LIB_DEPENDS+= abacus-osi:${PORTSDIR}/math/abacus
+USE_ABACUS= true
+USE_COIN= true
+.else
+USE_ABACUS= false
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '\
+ s|%%CXX%%|${CXX}|g; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g; \
+ s|%%USE_COIN%%|${USE_COIN}|g; \
+ s|%%USE_ABACUS%%|${USE_ABACUS}|g' \
+ ${WRKSRC}/makeMakefile.config
+
+do-configure:
+ cd ${WRKSRC} && ${PYTHON_CMD} makeMakefile.py
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/_release/libOGDF.so ${PREFIX}/lib/libOGDF.so.1
+ ${LN} -sf libOGDF.so.1 ${PREFIX}/lib/libOGDF.so
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ogdf ${PREFIX}/include
+
+.include <bsd.port.mk>