aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-ProvablePrime/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-05-11 11:05:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-05-11 11:05:10 +0000
commit828377ea61aab7a236b9fe6c2787d69d4c374179 (patch)
treec2ea9e0edabbfdd6b0f4cddeb426e1b9356a8dff /math/p5-Math-ProvablePrime/Makefile
parent46d248413984827f6112e94e28e30fd2c8db7d20 (diff)
downloadports-828377ea61aab7a236b9fe6c2787d69d4c374179.tar.gz
ports-828377ea61aab7a236b9fe6c2787d69d4c374179.zip
Notes
Diffstat (limited to 'math/p5-Math-ProvablePrime/Makefile')
-rw-r--r--math/p5-Math-ProvablePrime/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/p5-Math-ProvablePrime/Makefile b/math/p5-Math-ProvablePrime/Makefile
new file mode 100644
index 000000000000..67b4523bc888
--- /dev/null
+++ b/math/p5-Math-ProvablePrime/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= Math-ProvablePrime
+PORTVERSION= 0.043
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Generate a provable prime number, in pure Perl
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+PLIST_FILES= ${SITE_PERL_REL}/Math/ProvablePrime.pm \
+ ${SITE_PERL_REL}/Math/ProvablePrime/Rand.pm \
+ ${SITE_MAN3_REL}/Math::ProvablePrime.3.gz
+
+pre-install:
+ ${RM} ${WRKSRC}/blib/lib/Math/README.pod
+
+.include <bsd.port.mk>