aboutsummaryrefslogtreecommitdiff
path: root/math/py-cryptominisat
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-01 13:25:49 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-01 13:25:49 +0000
commit6d46f34aa3485070a91240ecd48c7d027266837c (patch)
treeff53f4571dcb5d0e31b2c1e4a761d292dbd2e8f7 /math/py-cryptominisat
parente9d553e07835bba537349f4b86cbe3478606432c (diff)
downloadports-6d46f34aa3485070a91240ecd48c7d027266837c.tar.gz
ports-6d46f34aa3485070a91240ecd48c7d027266837c.zip
- Update math/cryptominisat and math/py-cryptominisat to 5.0.0
PR: 211460 Submitted by: maintainer Reviewed by: koobs, feld (mentor) Approved by: feld (mentor)
Notes
Notes: svn path=/head/; revision=421212
Diffstat (limited to 'math/py-cryptominisat')
-rw-r--r--math/py-cryptominisat/Makefile5
-rw-r--r--math/py-cryptominisat/distinfo5
-rw-r--r--math/py-cryptominisat/files/patch-setup.py.in33
3 files changed, 27 insertions, 16 deletions
diff --git a/math/py-cryptominisat/Makefile b/math/py-cryptominisat/Makefile
index e3ed2b38094a..bbdd0e6e2e14 100644
--- a/math/py-cryptominisat/Makefile
+++ b/math/py-cryptominisat/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cryptominisat
-PORTVERSION= 4.5.3
+PORTVERSION= 5.0.0
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ COMMENT= Bindings to CryptoMiniSat (a SAT solver)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libcryptominisat4.so:math/cryptominisat
+LIB_DEPENDS= libcryptominisat5.so:math/cryptominisat
USES= compiler:c++11-lang python:-2.7
USE_PYTHON= autoplist distutils
@@ -24,6 +24,7 @@ WRKSRC_SUBDIR= python
PYDISTUTILS_BUILDTARGET= build_ext --include-dirs=${LOCALBASE}/include
post-patch:
+ ${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' ${WRKSRC}/setup.py.in
${CP} ${WRKSRC}/setup.py.in ${WRKSRC}/setup.py
post-install:
diff --git a/math/py-cryptominisat/distinfo b/math/py-cryptominisat/distinfo
index 0991145bbc4c..91a4e803148a 100644
--- a/math/py-cryptominisat/distinfo
+++ b/math/py-cryptominisat/distinfo
@@ -1,2 +1,3 @@
-SHA256 (msoos-cryptominisat-4.5.3_GH0.tar.gz) = 114da20e25734dc368dada47afd8cb7d44717f2159ad66d5bac742062fa3eb4c
-SIZE (msoos-cryptominisat-4.5.3_GH0.tar.gz) = 467221
+TIMESTAMP = 1469896511
+SHA256 (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 4c000daf9886e7c55f05b00247688ed0341a19cda13de49e2f35f40e95cc9910
+SIZE (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 596712
diff --git a/math/py-cryptominisat/files/patch-setup.py.in b/math/py-cryptominisat/files/patch-setup.py.in
index 660ac75c2a82..a4aebe2d558c 100644
--- a/math/py-cryptominisat/files/patch-setup.py.in
+++ b/math/py-cryptominisat/files/patch-setup.py.in
@@ -1,28 +1,37 @@
---- setup.py.in.orig 2015-08-26 23:32:30 UTC
+--- setup.py.in.orig 2016-07-06 12:22:54 UTC
+++ setup.py.in
-@@ -51,15 +51,15 @@ def _init_posix(init):
- return wrapper
- sysconfig._init_posix = _init_posix(sysconfig._init_posix)
+@@ -26,9 +26,9 @@ import sys
+ from distutils.core import setup, Extension
+ from distutils import sysconfig
--__version__ = '@PROJECT_VERSION@'
-+__version__ = '4.5.3'
+-cconf = """${PY_C_CONFIG}""".split(" ")
+-ldconf = """${PY_LD_CONFIG}""".split(" ")
+-is_apple = """${APPLE}"""
++cconf = """""".split(" ")
++ldconf = """""".split(" ")
++is_apple = """"""
+
+ def cleanup(dat):
+ ret = []
+@@ -81,12 +81,12 @@ __version__ = '@PROJECT_VERSION@'
ext_kwds = dict(
name = "pycryptosat",
- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/pycryptosat.cpp"],
+ sources = ["pycryptosat.cpp"],
define_macros = [],
-- extra_compile_args = ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat4-src'],
-+ extra_compile_args = ['-I/usr/local/include', '-I..cmsat4-src'],
+- extra_compile_args = cconf + ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat5-src'],
++ extra_compile_args = cconf + ['-I/usr/local/include', '-I../cmsat5-src'],
+ extra_link_args = ldconf,
language = "c++",
-- library_dirs=['.', '/usr/local/lib', '${PROJECT_BINARY_DIR}/lib'],
+- library_dirs=['.', '${PROJECT_BINARY_DIR}/lib'],
+ library_dirs=['.', '/usr/local/lib'],
- libraries = ['cryptominisat4']
+ libraries = ['cryptominisat5']
)
-@@ -84,5 +84,5 @@ setup(
+@@ -111,5 +111,5 @@ setup(
ext_modules = [Extension(**ext_kwds)],
- py_modules = ['test_pycryptosat'],
+ py_modules = ['pycryptosat'],
description = "bindings to CryptoMiniSat (a SAT solver)",
- long_description = open('${CMAKE_CURRENT_SOURCE_DIR}/README.rst').read(),
+ long_description = open('README.rst').read(),