aboutsummaryrefslogtreecommitdiff
path: root/math/py-pynndescent/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-25 07:26:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-25 07:26:38 +0000
commit63da43d0a1932db927c51d083c4758274b596287 (patch)
tree17e90e49f05e5c9379bd46216a9e96d9e242d15d /math/py-pynndescent/Makefile
parent97201eb2cb00659ab6ae177cd6fff0ace9871215 (diff)
downloadports-63da43d0a1932db927c51d083c4758274b596287.tar.gz
ports-63da43d0a1932db927c51d083c4758274b596287.zip
Notes
Diffstat (limited to 'math/py-pynndescent/Makefile')
-rw-r--r--math/py-pynndescent/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/py-pynndescent/Makefile b/math/py-pynndescent/Makefile
new file mode 100644
index 000000000000..e42e0a6e999a
--- /dev/null
+++ b/math/py-pynndescent/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pynndescent
+DISTVERSION= 0.4.4
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python nearest neighbor descent for approximate nearest neighbors
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}llvmlite>=0.30:devel/py-llvmlite@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numba>=0.46:devel/py-numba@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>