aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-05 18:57:40 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-05 18:57:40 +0000
commitafcba43610df67a9635588c60acc3aefd1e8a0d8 (patch)
tree560c85c068dfb772890d90c62ad3470a0c02f0f5 /math
parent6238c503310e2b50cc0a09054e1804e239200e21 (diff)
downloadports-afcba43610df67a9635588c60acc3aefd1e8a0d8.tar.gz
ports-afcba43610df67a9635588c60acc3aefd1e8a0d8.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile2
-rw-r--r--math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index fd254c167af9..c2f5219e53b8 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scilab
PORTVERSION= 5.5.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math cad java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
diff --git a/math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp b/math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp
new file mode 100644
index 000000000000..ce52281545cb
--- /dev/null
+++ b/math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp
@@ -0,0 +1,11 @@
+--- modules/output_stream/src/cpp/diary_manager.cpp.orig 2015-03-31 09:31:36 UTC
++++ modules/output_stream/src/cpp/diary_manager.cpp
+@@ -61,7 +61,7 @@ wchar_t **getDiaryFilenames(int *array_s
+ if (SCIDIARY)
+ {
+ std::wstring * wstringFilenames = SCIDIARY->getFilenames(array_size);
+- if (array_size > 0)
++ if (*array_size > 0)
+ {
+ wchar_t **wcFilenames = (wchar_t **) MALLOC (sizeof(wchar_t*) * (*array_size));
+ for (int i = 0; i < *array_size; i++)