aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile2
-rw-r--r--math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index fd254c167af9..c2f5219e53b8 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scilab
PORTVERSION= 5.5.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math cad java
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
diff --git a/math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp b/math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp
new file mode 100644
index 000000000000..ce52281545cb
--- /dev/null
+++ b/math/scilab/files/patch-modules_output__stream_src_cpp_diary__manager.cpp
@@ -0,0 +1,11 @@
+--- modules/output_stream/src/cpp/diary_manager.cpp.orig 2015-03-31 09:31:36 UTC
++++ modules/output_stream/src/cpp/diary_manager.cpp
+@@ -61,7 +61,7 @@ wchar_t **getDiaryFilenames(int *array_s
+ if (SCIDIARY)
+ {
+ std::wstring * wstringFilenames = SCIDIARY->getFilenames(array_size);
+- if (array_size > 0)
++ if (*array_size > 0)
+ {
+ wchar_t **wcFilenames = (wchar_t **) MALLOC (sizeof(wchar_t*) * (*array_size));
+ for (int i = 0; i < *array_size; i++)