aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 03:29:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:19:56 +0000
commitcc57c3d5cf115fcc2b155ea36dd8763b31973a21 (patch)
tree6ea1decbb45ed330d786845dec4e258589d5938c /math
parente9c7d2b48706794ce8f5c582d0edd7913d20c3f3 (diff)
downloadports-cc57c3d5cf115fcc2b155ea36dd8763b31973a21.tar.gz
ports-cc57c3d5cf115fcc2b155ea36dd8763b31973a21.zip
math/flint2: Add explicit Python build dependency (D29353)
This unbreaks the build when using devel/samurai. It previously got it through ninja which has a run dependency on Python. CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:218 (message): Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:582 (_FPHSA_FAILURE_MESSAGE) /usr/local/share/cmake/Modules/FindPythonInterp.cmake:169 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:37 (find_package) http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-04_07h37m38s/logs/errors/flint2-2.7.1.log PR: 254678
Diffstat (limited to 'math')
-rw-r--r--math/flint2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/flint2/Makefile b/math/flint2/Makefile
index 4da902f4d8df..62a4cd9bae3e 100644
--- a/math/flint2/Makefile
+++ b/math/flint2/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libopenblas.so:math/openblas
-USES= cmake compiler:c++11-lang
+USES= cmake compiler:c++11-lang python:build
USE_GITHUB= yes
GH_ACCOUNT= wbhart
USE_LDCONFIG= yes