aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:43:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:43:57 +0000
commit6d0bc2e99ac97a6112ec225da768d2e9eec95b8c (patch)
treec181ef0e42be10456572561536e4fd6cacc1da01 /misc
parent15afb458d7a59b7a848b69f47b76a34ecaa30cbc (diff)
downloadports-6d0bc2e99ac97a6112ec225da768d2e9eec95b8c.tar.gz
ports-6d0bc2e99ac97a6112ec225da768d2e9eec95b8c.zip
Notes
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-Mapquest/Makefile38
-rw-r--r--misc/p5-Geo-Coder-Mapquest/distinfo2
-rw-r--r--misc/p5-Geo-Coder-Mapquest/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-Mapquest/pkg-plist7
5 files changed, 52 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index c44f394221e7..d16009b32953 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -404,6 +404,7 @@
SUBDIR += p5-Geo-Coder-Bing
SUBDIR += p5-Geo-Coder-Google
SUBDIR += p5-Geo-Coder-Googlev3
+ SUBDIR += p5-Geo-Coder-Mapquest
SUBDIR += p5-Geo-Coder-Multiple
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
diff --git a/misc/p5-Geo-Coder-Mapquest/Makefile b/misc/p5-Geo-Coder-Mapquest/Makefile
new file mode 100644
index 000000000000..59506ea3859c
--- /dev/null
+++ b/misc/p5-Geo-Coder-Mapquest/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-Geo-Coder-Mapquest
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Mapquest
+PORTVERSION= 0.05
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with Mapquest
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-LWP-Protocol-https>=6.02:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=6.02:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-LWP-Protocol-https>=6.02:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=6.02:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Mapquest.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-Mapquest/distinfo b/misc/p5-Geo-Coder-Mapquest/distinfo
new file mode 100644
index 000000000000..dc3c47b3987c
--- /dev/null
+++ b/misc/p5-Geo-Coder-Mapquest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-Mapquest-0.05.tar.gz) = 8f077071b36ac7facc04d8ea1c02c2bc6fd5f47f049d2b8db015fa675f765589
+SIZE (Geo-Coder-Mapquest-0.05.tar.gz) = 6950
diff --git a/misc/p5-Geo-Coder-Mapquest/pkg-descr b/misc/p5-Geo-Coder-Mapquest/pkg-descr
new file mode 100644
index 000000000000..1391c31a8a51
--- /dev/null
+++ b/misc/p5-Geo-Coder-Mapquest/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::Mapquest provides an interface to the Mapquest Geocoding Web
+Service.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Mapquest/
diff --git a/misc/p5-Geo-Coder-Mapquest/pkg-plist b/misc/p5-Geo-Coder-Mapquest/pkg-plist
new file mode 100644
index 000000000000..4c9539d1ef26
--- /dev/null
+++ b/misc/p5-Geo-Coder-Mapquest/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/Mapquest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Mapquest/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Mapquest
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo