aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-04-21 06:02:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-04-21 06:29:05 +0000
commitfe254a6435bbe85f5e6c42a52de80e5b713df63e (patch)
treeaa198b81c09364f8c7721e75997db3b8ae7188e0 /misc
parent089d935ab16b1ed209b2820c1652f38e023e1d6e (diff)
downloadports-fe254a6435bbe85f5e6c42a52de80e5b713df63e.tar.gz
ports-fe254a6435bbe85f5e6c42a52de80e5b713df63e.zip
misc/qt5ct: update to 1.2
- switch to cmake
Diffstat (limited to 'misc')
-rw-r--r--misc/qt5ct/Makefile8
-rw-r--r--misc/qt5ct/distinfo6
-rw-r--r--misc/qt5ct/files/patch-CMakeLists.txt13
3 files changed, 20 insertions, 7 deletions
diff --git a/misc/qt5ct/Makefile b/misc/qt5ct/Makefile
index db991a0af4b4..e4e3ec68c8b6 100644
--- a/misc/qt5ct/Makefile
+++ b/misc/qt5ct/Makefile
@@ -1,5 +1,5 @@
PORTNAME= qt5ct
-DISTVERSION= 1.1
+DISTVERSION= 1.2
CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}
@@ -11,10 +11,10 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= compiler:c++11-lang gettext-runtime gl gnome qmake \
+USES= cmake compiler:c++11-lang gettext-runtime gl gnome \
qt:5 tar:bz2 xorg
-USE_QT= concurrent core dbus gui svg widgets \
- buildtools_build linguisttools_build
+USE_QT= concurrent core dbus gui paths svg widgets \
+ buildtools_build linguisttools_build qmake_build
USE_GL= egl gl
USE_XORG= x11 xext xrender
USE_GNOME= glib20
diff --git a/misc/qt5ct/distinfo b/misc/qt5ct/distinfo
index 774c201e0918..9a220b94d31a 100644
--- a/misc/qt5ct/distinfo
+++ b/misc/qt5ct/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595531306
-SHA256 (qt5ct-1.1.tar.bz2) = af77c4dbf7f9ba97fe0218648167395bca7bcb2b9c1886a9c98b1e343127ddd2
-SIZE (qt5ct-1.1.tar.bz2) = 79890
+TIMESTAMP = 1618982833
+SHA256 (qt5ct-1.2.tar.bz2) = 1de3f06e6d5d0746bf19a949e56cc04b53bdbc18294f38cb20759f35006b872e
+SIZE (qt5ct-1.2.tar.bz2) = 76052
diff --git a/misc/qt5ct/files/patch-CMakeLists.txt b/misc/qt5ct/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e97da5c3ab9a
--- /dev/null
+++ b/misc/qt5ct/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2021-04-21 05:59:00 UTC
++++ CMakeLists.txt
+@@ -54,8 +54,8 @@ add_subdirectory(src/qt5ct)
+ add_subdirectory(src/qt5ct-qtplugin)
+ add_subdirectory(src/qt5ct-style)
+
+-install(DIRECTORY qss DESTINATION ${CMAKE_INSTALL_DATADIR})
+-install(DIRECTORY colors DESTINATION ${CMAKE_INSTALL_DATADIR})
++install(DIRECTORY qss DESTINATION ${CMAKE_INSTALL_DATADIR}/qt5ct)
++install(DIRECTORY colors DESTINATION ${CMAKE_INSTALL_DATADIR}/qt5ct)
+
+ if(UNIX)
+ add_custom_target(distclean @echo cleaning for source distribution)