aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-plugins
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-12-18 06:13:52 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-12-18 06:13:52 +0000
commit41a9ac7e3f29ce4b8321559b659ab526b8a0ed4d (patch)
tree4f0aeb8a1f65a77fd51e494b72178fa783c42729 /multimedia/gstreamer1-plugins
parent12595774297cb507d9d63ff26def15d7a852f516 (diff)
downloadports-41a9ac7e3f29ce4b8321559b659ab526b8a0ed4d.tar.gz
ports-41a9ac7e3f29ce4b8321559b659ab526b8a0ed4d.zip
multimedia/intel-media-sdk: add new port
Intel(R) Media SDK provides a plain C API to access hardware-accelerated video decode, encode and filtering on Intel(R) Gen graphics hardware platforms. Implementation written in C++ 11 with parts in C-for-Media (CM). Supported video encoders: HEVC, AVC, MPEG-2, JPEG, VP9 Supported video decoders: HEVC, AVC, VP8, VP9, MPEG-2, VC1, JPEG Supported video pre-processing filters: Color Conversion, Deinterlace, Denoise, Resize, Rotate, Composition http://mediasdk.intel.com/
Notes
Notes: svn path=/head/; revision=520364
Diffstat (limited to 'multimedia/gstreamer1-plugins')
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common8
1 files changed, 7 insertions, 1 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index 527333e04db7..bf2053376550 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -44,6 +44,7 @@ BAD_GST_ALL_PLUGINS+= \
modplug \
mpeg2enc \
mplex \
+ msdk \
musepack \
neon \
ofa \
@@ -83,7 +84,6 @@ BAD_GST_NON_PLUGINS= \
--disable-directfb \
--disable-direct3d \
--disable-directsound \
- --disable-msdk \
--disable-nvenc \
--disable-nvdec \
--disable-sbc \
@@ -361,6 +361,12 @@ gst_mplex_LIB_DEPENDS= libmplex2.so:multimedia/mjpegtools
# mpg123
gst_mpg123_LIB_DEPENDS= libmpg123.so:audio/mpg123
+# msdk
+gst_msdk_LIB_DEPENDS= libgudev-1.0.so:devel/libgudev \
+ libmfx.so:multimedia/intel-media-sdk \
+ libva-drm.so:multimedia/libva
+gst_msdk_GST_PLUGIN_DIR= sys/msdk
+
# musepack
gst_musepack_LIB_DEPENDS=libmpcdec.so:audio/musepack