aboutsummaryrefslogtreecommitdiff
path: root/multimedia/simplescreenrecorder/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:08:16 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:08:16 +0000
commit0ee05daf613ea037b93b43b1a4d00209dddef65f (patch)
tree382fc5a418964b8b40b4b0e4288ff19367a48b9f /multimedia/simplescreenrecorder/Makefile
parentad0b4f5ea49c59b81d8b44f1d55a313a421fab57 (diff)
downloadports-0ee05daf613ea037b93b43b1a4d00209dddef65f.tar.gz
ports-0ee05daf613ea037b93b43b1a4d00209dddef65f.zip
Notes
Diffstat (limited to 'multimedia/simplescreenrecorder/Makefile')
-rw-r--r--multimedia/simplescreenrecorder/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/multimedia/simplescreenrecorder/Makefile b/multimedia/simplescreenrecorder/Makefile
new file mode 100644
index 000000000000..092cfc14f707
--- /dev/null
+++ b/multimedia/simplescreenrecorder/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= simplescreenrecorder
+DISTVERSION= 0.3.8-26
+DISTVERSIONSUFFIX= -g0f6eebf
+CATEGORIES= multimedia
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Screen video recorder
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libavformat.so:multimedia/ffmpeg
+
+USES= gmake localbase libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= MaartenBaert
+GH_PROJECT= ssr
+USE_GL= gl glu
+USE_QT4= corelib gui moc_build rcc_build uic_build linguisttools_build
+USE_XORG= x11 xext xfixes xi
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-assert
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= PULSEAUDIO JACK
+OPTIONS_DEFAULT= PULSEAUDIO
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+JACK_CONFIGURE_WITH= jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|-ldl([". ])|-lc\1|g' \
+ -e 's|-ldl$$|-lc|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>