aboutsummaryrefslogtreecommitdiff
path: root/net-im/nheko/Makefile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-03-06 21:32:42 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-03-06 21:34:19 +0000
commit3450e834d4e19eef34def6ba009fc94ca70e8c66 (patch)
tree32f5d7383c76b686e893494543b19310c487b4b4 /net-im/nheko/Makefile
parent40b7d72e022a0c1db66feaf306888639774662bc (diff)
downloadports-3450e834d4e19eef34def6ba009fc94ca70e8c66.tar.gz
ports-3450e834d4e19eef34def6ba009fc94ca70e8c66.zip
Diffstat (limited to 'net-im/nheko/Makefile')
-rw-r--r--net-im/nheko/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index bbefd843b8d6..9e4a59365576 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -1,7 +1,6 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
-DISTVERSION= 0.10.2
-PORTREVISION= 1
+DISTVERSION= 0.11.3
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -32,10 +31,20 @@ USE_QT= concurrent core dbus declarative gui multimedia network \
graphicaleffects:run \
buildtools:build linguist:build qmake:build
+OPTIONS_DEFINE= VOIP
+OPTIONS_DEFAULT=
+
+VOIP_DESC= Enable VOIP calls (experimental)
+VOIP_CMAKE_BOOL= VOIP
+VOIP_USES= gstreamer gettext-runtime
+VOIP_USE_GSTREAMER1= bad dtls srtp
+VOIP_USE_XORG= xcb
+VOIP_USE_GNOME= glib20
+VOIP_LIB_DEPENDS= libnice.so:net-im/libnice
+
# There is one external dependency: lmdb++
# - lmdb++ is a single header file, it just needs to be included
CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb \
- -DVOIP=OFF \
-DCMAKE_INSTALL_MANDIR=share/man
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
LDFLAGS+= -L${LOCALBASE}/lib -lfmt