aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-accounts-signon
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-07-06 15:18:01 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-07-06 15:18:01 +0000
commit2b11990f8efab7fad2e491a31647ab25889df4a0 (patch)
treed8fdf2bb409f7920f3c05ca6a6b15ed94fb48640 /net-im/telepathy-accounts-signon
parent8760300d5b358c07f72a2e6afb6ab4022a5f3016 (diff)
downloadports-2b11990f8efab7fad2e491a31647ab25889df4a0.tar.gz
ports-2b11990f8efab7fad2e491a31647ab25889df4a0.zip
Add ports for future KDE Telepathy versions
The current relases of KDE Telepathy require some more helper libraries to work. Import them from kde@'s development repository into the ports tree in preparation. PR: 220494 Reviewed by: groot_kde.org, rakuco Differential Revision: https://reviews.freebsd.org/D11213
Notes
Notes: svn path=/head/; revision=445159
Diffstat (limited to 'net-im/telepathy-accounts-signon')
-rw-r--r--net-im/telepathy-accounts-signon/Makefile33
-rw-r--r--net-im/telepathy-accounts-signon/distinfo3
-rw-r--r--net-im/telepathy-accounts-signon/pkg-descr5
3 files changed, 41 insertions, 0 deletions
diff --git a/net-im/telepathy-accounts-signon/Makefile b/net-im/telepathy-accounts-signon/Makefile
new file mode 100644
index 000000000000..62e724811699
--- /dev/null
+++ b/net-im/telepathy-accounts-signon/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= ${GL_PROJECT}
+PORTVERSION= 1.0
+CATEGORIES= net-im
+MASTER_SITES= https://gitlab.com/${GL_ACCOUNT}/${GL_PROJECT}/repository/archive${EXTRACT_SUFX}?ref=${GL_TAGNAME}&num;/ \
+ LOCAL/tcberner/${GL_ACCOUNT}/
+DIST_SUBDIR= KDE/${GL_ACCOUNT}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Telepathy libaccounts and libsignon plugin
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
+
+LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib \
+ libmission-control-plugins.so:net-im/telepathy-mission-control \
+ libsignon-glib.so:net-im/libsignon-glib
+
+USES= gettext pkgconfig qmake tar:bz2
+USE_QT5= buildtools_build core qmake_build
+
+USE_LDCONFIG= YES
+
+# gitlab variables
+GL_ACCOUNT= accounts-sso
+GL_PROJECT= telepathy-accounts-signon
+GL_TAGNAME= f01a6d9eccad24a3cb4a5300fb0ae0fd426cc815
+WRKSRC= ${WRKDIR}/${GL_PROJECT}-${GL_TAGNAME}-${GL_TAGNAME}
+
+PLIST_FILES= lib/mission-control-plugins.0/mcp-account-manager-accounts-sso.so
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-accounts-signon/distinfo b/net-im/telepathy-accounts-signon/distinfo
new file mode 100644
index 000000000000..a3316c72eb28
--- /dev/null
+++ b/net-im/telepathy-accounts-signon/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470554779
+SHA256 (KDE/accounts-sso/telepathy-accounts-signon-1.0.tar.bz2) = 42d16d0f96bb9d60b3d7e9f42cc505fc6bc4e02fee0fcb3e9afd159e4e7197cf
+SIZE (KDE/accounts-sso/telepathy-accounts-signon-1.0.tar.bz2) = 15528
diff --git a/net-im/telepathy-accounts-signon/pkg-descr b/net-im/telepathy-accounts-signon/pkg-descr
new file mode 100644
index 000000000000..8c0e2c61f76d
--- /dev/null
+++ b/net-im/telepathy-accounts-signon/pkg-descr
@@ -0,0 +1,5 @@
+A mission control plugin for Telepathy, integrating with libaccounts and libsignon
+to provide IM accounts and authentication. This code is based on Nemo Mobile's
+fork of the plugin from Empathy's ubuntu-online-account support.
+
+WWW: https://gitlab.com/accounts-sso/telepathy-accounts-signon