aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-salut/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/telepathy-salut/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'net-im/telepathy-salut/Makefile')
-rw-r--r--net-im/telepathy-salut/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 16a4a6c12d11..3e6e39709bb3 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -1,36 +1,28 @@
-# New ports collection makefile for: telepathy-salut
-# Date created: Apr 16 2007
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-salut/Makefile,v 1.4 2009/01/08 07:12:15 marcus Exp $
-#
+# $MCom: ports/net-im/telepathy-salut/Makefile,v 1.9 2012/08/17 19:06:46 kwm Exp $
PORTNAME= telepathy-salut
-PORTVERSION= 0.4.0
+PORTVERSION= 0.8.0
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Link-local Connection Manager for Telepathy Framework
-LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
- avahi-glib.pc:${PORTSDIR}/net/avahi-app \
- telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
- libsoup-2.4.pc:${PORTSDIR}/devel/libsoup
-
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+LIB_DEPENDS= avahi-glib.1:${PORTSDIR}/net/avahi-app \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack glib20 libxslt:build
+USE_PKGCONFIG= build
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+USE_SQLITE= 3
+CONFIGURE_ARGS= --disable-Werror --enable-avahi-tests=no
CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
MAN8= telepathy-salut.8