aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/riemann-c-client
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-01 23:34:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-01 23:34:12 +0000
commit943851900e74ce3522f18c84a2398f14d48c896c (patch)
tree97e66c87b5967cbee5caf9212cff016302da54aa /net-mgmt/riemann-c-client
parentd7f028de60cc8910eb519ba4b49e95456e050c35 (diff)
downloadports-943851900e74ce3522f18c84a2398f14d48c896c.tar.gz
ports-943851900e74ce3522f18c84a2398f14d48c896c.zip
net-mgmt/riemann-c-client: add new port
PR: 210545 Submitted by: Dave Cottlehuber <dch@skunkwerks.at> Riemann-C-client is a C client library for the Riemann monitoring system, providing a convenient and simple API, high test coverage and a copyleft license, along with API and ABI stability. https://github.com/algernon/riemann-c-client/#readme
Notes
Notes: svn path=/head/; revision=423096
Diffstat (limited to 'net-mgmt/riemann-c-client')
-rw-r--r--net-mgmt/riemann-c-client/Makefile36
-rw-r--r--net-mgmt/riemann-c-client/distinfo3
-rw-r--r--net-mgmt/riemann-c-client/pkg-descr5
-rw-r--r--net-mgmt/riemann-c-client/pkg-plist15
4 files changed, 59 insertions, 0 deletions
diff --git a/net-mgmt/riemann-c-client/Makefile b/net-mgmt/riemann-c-client/Makefile
new file mode 100644
index 000000000000..f81fcea46dc9
--- /dev/null
+++ b/net-mgmt/riemann-c-client/Makefile
@@ -0,0 +1,36 @@
+# Created by: Dave Cottlehuber <dch@skunkwerks.at>
+# $FreeBSD$
+
+PORTNAME= riemann-c-client
+PORTVERSION= 1.9.1
+DISTVERSIONPREFIX= ${PORTNAME}-
+CATEGORIES= net-mgmt
+
+MAINTAINER= dch@skunkwerks.at
+COMMENT= C library and command-line tool for Riemann
+
+LICENSE= LGPL3+
+
+BUILD_DEPENDS= libcheck>0:devel/libcheck
+LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c \
+ libgnutls.so:security/gnutls \
+ libjson-c.so:devel/json-c
+
+USE_GITHUB= yes
+GH_ACCOUNT= algernon
+
+USES= autoreconf gmake libtool pathfix pkgconfig
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+PATHFIX_MAKEFILEIN= Makefile.am
+INSTALL_TARGET= install-strip
+TEST_TARGET= check
+
+post-patch:
+ @${REINPLACE_CMD} 's/-ldl//' ${WRKSRC}/Makefile.am
+
+# Running |make test| isn't on poudriere menu yet, so force-feed
+pre-install: do-test
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/riemann-c-client/distinfo b/net-mgmt/riemann-c-client/distinfo
new file mode 100644
index 000000000000..7ac624f669ec
--- /dev/null
+++ b/net-mgmt/riemann-c-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475271779
+SHA256 (algernon-riemann-c-client-riemann-c-client-1.9.1_GH0.tar.gz) = 6c8279362384e0ee01cb84a12f645bf7229c7d61f565158fe4ecc82c36ce8dc0
+SIZE (algernon-riemann-c-client-riemann-c-client-1.9.1_GH0.tar.gz) = 74563
diff --git a/net-mgmt/riemann-c-client/pkg-descr b/net-mgmt/riemann-c-client/pkg-descr
new file mode 100644
index 000000000000..449b8b87a414
--- /dev/null
+++ b/net-mgmt/riemann-c-client/pkg-descr
@@ -0,0 +1,5 @@
+Riemann-C-client is a C client library for the Riemann monitoring system,
+providing a convenient and simple API, high test coverage and a copyleft
+license, along with API and ABI stability.
+
+WWW: https://github.com/algernon/riemann-c-client/#readme
diff --git a/net-mgmt/riemann-c-client/pkg-plist b/net-mgmt/riemann-c-client/pkg-plist
new file mode 100644
index 000000000000..da3a1d7742a3
--- /dev/null
+++ b/net-mgmt/riemann-c-client/pkg-plist
@@ -0,0 +1,15 @@
+bin/riemann-client
+include/riemann/attribute.h
+include/riemann/client.h
+include/riemann/event.h
+include/riemann/message.h
+include/riemann/proto/riemann.pb-c.h
+include/riemann/query.h
+include/riemann/riemann-client.h
+include/riemann/simple.h
+lib/libriemann-client.a
+lib/libriemann-client.so
+lib/libriemann-client.so.0
+lib/libriemann-client.so.0.9.1
+libdata/pkgconfig/riemann-client.pc
+man/man1/riemann-client.1.gz