aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-03-23 16:57:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-03-23 16:57:36 +0000
commit9a38a22c124021dc6d6c7e8cd7c8ccab095f1626 (patch)
tree6b3c2b869c3f9c413400fdea27a35f01e15cff56 /net-mgmt
parent561050a25d283958f7f2a856138f7eca7ef9bc2f (diff)
downloadports-9a38a22c124021dc6d6c7e8cd7c8ccab095f1626.tar.gz
ports-9a38a22c124021dc6d6c7e8cd7c8ccab095f1626.zip
net-mgmt/nagstamon: Fix build with Python 3.8 and onward
While here, pacify portclippy/portfmt. PR: 254502 Submitted by: kai Reference: https://github.com/HenriWahl/Nagstamon/pull/705
Notes
Notes: svn path=/head/; revision=569040
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagstamon/Makefile8
-rw-r--r--net-mgmt/nagstamon/files/patch-setup.py12
2 files changed, 16 insertions, 4 deletions
diff --git a/net-mgmt/nagstamon/Makefile b/net-mgmt/nagstamon/Makefile
index 8d87d89fb1ee..11d0964f5fc2 100644
--- a/net-mgmt/nagstamon/Makefile
+++ b/net-mgmt/nagstamon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagstamon
PORTVERSION= 3.4.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt python
MASTER_SITES= https://nagstamon.ifw-dresden.de/files/stable/ \
LOCAL/ehaupt
@@ -22,12 +22,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.2.1:www/py-beautifulsoup@${
${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-kerberos>0:security/py-requests-kerberos@${PY_FLAVOR}
-USES= cpe python:3.6+ pyqt:5
-USE_PYTHON= autoplist distutils noflavors
+USES= cpe pyqt:5 python:3.6+
+CPE_VENDOR= henri_wahl
USE_PYQT= core_run dbus_run gui_run multimedia_run network_run sip_run \
svg_run widgets_run
+USE_PYTHON= autoplist distutils noflavors
-CPE_VENDOR= henri_wahl
NO_ARCH= yes
WRKSRC= ${WRKDIR}/Nagstamon
diff --git a/net-mgmt/nagstamon/files/patch-setup.py b/net-mgmt/nagstamon/files/patch-setup.py
new file mode 100644
index 000000000000..485eaf60021c
--- /dev/null
+++ b/net-mgmt/nagstamon/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2021-03-22 15:58:33 UTC
++++ setup.py
+@@ -36,6 +36,9 @@ OS = platform.system()
+ if OS not in ['Windows', 'Darwin']:
+ if OS == 'Linux':
+ DIST, DIST_VERSION, DIST_NAME = get_distro()
++ # platform.dist() returns "('', '', '')" on FreeBSD
++ elif OS == 'FreeBSD':
++ DIST, DIST_VERSION, DIST_NAME = ('', '', '')
+ else:
+ DIST, DIST_VERSION, DIST_NAME = platform.dist()
+ NAME = NAME.lower()