aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-02-17 02:33:20 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-02-17 02:33:20 +0000
commit8379c973c9f5e00a06366396f46717560f8e35d2 (patch)
tree3496b2d32afc4ef47dd7315c891dd9a719efb577 /net-p2p/deluge
parent59d2804b09ac0a36431c3734129721ec4cfa040c (diff)
downloadports-8379c973c9f5e00a06366396f46717560f8e35d2.tar.gz
ports-8379c973c9f5e00a06366396f46717560f8e35d2.zip
Notes
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/Makefile14
-rw-r--r--net-p2p/deluge/files/extra-patch-deluge__main.py16
2 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 00c4503f5168..49aad9c45621 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -29,6 +29,8 @@ USE_PYTHON= yes
USE_GCC= 4.3+
MAKE_ENV= PYTHONPATH="${PYTHONPREFIX_SITELIBDIR}"
+OPTIONS= PSYCO "Enable devel/py-psyco optimization support (i386)" off
+
MAN1= deluge.1 deluged.1
PLIST_SUB= VERSION="${PORTVERSION}" PYTHON_VER="${PYTHON_VER}"
@@ -43,6 +45,18 @@ INSTALLS_ICONS= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+.undef WITH_PSYCO
+
+WITHOUT_PSYCO= yes
+.endif
+
+.if defined(WITH_PSYCO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-deluge__main.py
+.endif
+
.if (exists(${LOCALBASE}/lib/libboost_iostreams.so) && \
!exists(${LOCALBASE}/lib/libboost_python.so))
IGNORE= cannot find dependency: The boost exists but not with Python support. Please uninstall boost and install boost-python or reinstall boost with Python support
diff --git a/net-p2p/deluge/files/extra-patch-deluge__main.py b/net-p2p/deluge/files/extra-patch-deluge__main.py
new file mode 100644
index 000000000000..11d20ee229d9
--- /dev/null
+++ b/net-p2p/deluge/files/extra-patch-deluge__main.py
@@ -0,0 +1,16 @@
+--- deluge/main.py.orig 2010-02-17 00:17:31.000000000 -0200
++++ deluge/main.py 2010-02-17 00:18:56.000000000 -0200
+@@ -34,6 +34,13 @@
+
+ #
+
++try:
++ import psyco
++ import re
++ psyco.cannotcompile(re.compile)
++ psyco.profile()
++except ImportError:
++ pass
+
+ # The main starting point for the program. This function is called when the
+ # user runs the command 'deluge'.