aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission25-daemon
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-08-10 19:59:17 +0000
committerChris Rees <crees@FreeBSD.org>2012-08-10 19:59:17 +0000
commite01c71c7b1be66fe9acf16d53d3b867b51fee053 (patch)
tree6601ec287b09d6b34b6c1e164de43603a1a0d116 /net-p2p/transmission25-daemon
parent67dbda2115277e4457ee6fc8809d07e1263929c0 (diff)
Create transmission25 ports and UPDATING entry to explain.
Sadly, Transmission has stopped supporting GTK 2.0 (it had to happen some day). They now require GTK 3.2.0 [1], which we currently lack, so for those who wish to use the GTK frontend need to stay on version 2.5 When our GTK is upgraded I'll make MOVED entries to make the transition back to 2.6 as seamless as possible. [1] http://tinyurl.com/cfchfp9
Notes
Notes: svn path=/head/; revision=302400
Diffstat (limited to 'net-p2p/transmission25-daemon')
-rw-r--r--net-p2p/transmission25-daemon/Makefile38
-rw-r--r--net-p2p/transmission25-daemon/pkg-descr11
-rw-r--r--net-p2p/transmission25-daemon/pkg-install46
-rw-r--r--net-p2p/transmission25-daemon/pkg-plist10
4 files changed, 105 insertions, 0 deletions
diff --git a/net-p2p/transmission25-daemon/Makefile b/net-p2p/transmission25-daemon/Makefile
new file mode 100644
index 000000000000..c0637ae1557f
--- /dev/null
+++ b/net-p2p/transmission25-daemon/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: transmission-daemon
+# Date created: 08 February 2008
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -daemon
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= A fast and lightweight daemon BitTorrent client
+
+RUN_DEPENDS= ${GEN_RUN_DEPENDS}
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission25-cli
+PLIST= ${.CURDIR}/pkg-plist
+PKGINSTALL= ${.CURDIR}/pkg-install
+SLAVEPORT= daemon
+
+USE_RC_SUBR= transmission
+
+EXTRA_CONF_ARGS=--disable-cli \
+ --enable-daemon \
+ --without-gtk \
+ --disable-mac \
+ --disable-nls
+
+MAN1= transmission-daemon.1 transmission-remote.1
+
+post-install: general-install
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission25-daemon/pkg-descr b/net-p2p/transmission25-daemon/pkg-descr
new file mode 100644
index 000000000000..d609b375191d
--- /dev/null
+++ b/net-p2p/transmission25-daemon/pkg-descr
@@ -0,0 +1,11 @@
+The transmission-daemon is a daemon-based Transmission session that can
+be controlled via RPC by transmission-remote (included) and other
+Transmission BiTtorrent client such as GTK+ and CLI interface.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission25-daemon/pkg-install b/net-p2p/transmission25-daemon/pkg-install
new file mode 100644
index 000000000000..7d6ee9b0a832
--- /dev/null
+++ b/net-p2p/transmission25-daemon/pkg-install
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+case $2 in
+POST-INSTALL)
+ USER=transmission
+ GROUP=${USER}
+ UID=921
+ GID=${UID}
+ PW=/usr/sbin/pw
+ CHMOD=/bin/chmod
+ CHOWN=/usr/sbin/chown
+ MKDIR=/bin/mkdir
+ THOME=${PKG_PREFIX}/etc/${USER}/home
+
+ if ${PW} group show "${GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if ${PW} groupadd ${GROUP} -g ${GID}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if ${PW} user show "${USER}" 2>/dev/null; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if ${PW} useradd ${USER} -u ${UID} -g ${GROUP} -h - \
+ -d "${THOME}" -s /usr/sbin/nologin -c "Transmission Daemon User"
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+ fi
+
+ ${MKDIR} -p ${THOME}/Downloads
+ ${CHOWN} root:${GROUP} ${THOME}
+ ${CHOWN} ${USER}:${GROUP} ${THOME}/Downloads
+ ${CHMOD} 1770 ${THOME}
+
+ exit 0
+ ;;
+esac
diff --git a/net-p2p/transmission25-daemon/pkg-plist b/net-p2p/transmission25-daemon/pkg-plist
new file mode 100644
index 000000000000..e7cb3d4f583f
--- /dev/null
+++ b/net-p2p/transmission25-daemon/pkg-plist
@@ -0,0 +1,10 @@
+bin/transmission-daemon
+bin/transmission-remote
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry etc/transmission/home/Downloads
+@dirrmtry etc/transmission/home
+@dirrmtry etc/transmission