aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpd/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-09-19 12:20:32 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-09-19 12:20:32 +0000
commit4476787a1812f8a15f1fe9a862d36176a5f89df8 (patch)
treea300aeb10ed39b698c3b5bcc61c5422dfc17b663 /net/miniupnpd/Makefile
parent4e7dc1cf18fc93b30ceae1ee8ddffc51c2804ff6 (diff)
downloadports-4476787a1812f8a15f1fe9a862d36176a5f89df8.tar.gz
ports-4476787a1812f8a15f1fe9a862d36176a5f89df8.zip
Notes
Diffstat (limited to 'net/miniupnpd/Makefile')
-rw-r--r--net/miniupnpd/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index adba2f60b24b..3b64596096d1 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= miniupnpd
-PORTVERSION= 1.9
-PORTREVISION= 1
+PORTVERSION= 1.9.20150721
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
@@ -12,12 +11,10 @@ MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
MAINTAINER= squat@squat.no
COMMENT= UPnP IGD implementation which uses pf/ipf
-SUB_FILES= miniupnpd.conf.sample
-SUB_LIST= UUID=${UUID}
+LICENSE= BSD3CLAUSE
USES= cpe
CPE_VENDOR= miniupnp_project
-UUID!= uuidgen
PLIST_FILES= etc/miniupnpd.conf.sample sbin/miniupnpd \
man/man8/miniupnpd.8.gz
MAKE_JOBS_UNSAFE=yes
@@ -42,15 +39,4 @@ UPNP_IGDV2_EXTRA_PATCHES= ${PATCHDIR}/enable_igdv2.patch
UPNP_STRICT_EXTRA_PATCHES= ${PATCHDIR}/enable_upnp_strict.patch
LEASEFILE_EXTRA_PATCHES= ${PATCHDIR}/enable_leasefile.patch
-post-patch:
- @${REINPLACE_CMD} 's|CFLAGS ?= -pipe -Os|CFLAGS ?= -pipe|' \
- ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKDIR}/miniupnpd.conf.sample \
- ${STAGEDIR}${PREFIX}/etc/miniupnpd.conf.sample
- ${INSTALL_MAN} ${WRKSRC}/miniupnpd.8 \
- ${STAGEDIR}${MAN8PREFIX}/man/man8/miniupnpd.8
-
.include <bsd.port.mk>