aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Geo
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net/pear-Net_Geo
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'net/pear-Net_Geo')
-rw-r--r--net/pear-Net_Geo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/pear-Net_Geo/Makefile b/net/pear-Net_Geo/Makefile
index b67b14975b63..db027c93b297 100644
--- a/net/pear-Net_Geo/Makefile
+++ b/net/pear-Net_Geo/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= net pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= Geographical locations based on Internet address
-BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
+BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
USES= pear