aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Socket
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
commit050dd1b1031022b49cd1623dd3892f3c4be3a1ae (patch)
tree0876fb5cc1d38a316c0fbaf87137d69775f5dad0 /net/pear-Net_Socket
parentcf19879c06b65241c187f1b0663a0db0270be14f (diff)
downloadports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.tar.gz
ports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=70285
Diffstat (limited to 'net/pear-Net_Socket')
-rw-r--r--net/pear-Net_Socket/Makefile36
-rw-r--r--net/pear-Net_Socket/distinfo1
-rw-r--r--net/pear-Net_Socket/pkg-comment1
-rw-r--r--net/pear-Net_Socket/pkg-descr7
-rw-r--r--net/pear-Net_Socket/pkg-plist1
5 files changed, 46 insertions, 0 deletions
diff --git a/net/pear-Net_Socket/Makefile b/net/pear-Net_Socket/Makefile
new file mode 100644
index 000000000000..1d830b2cf1ad
--- /dev/null
+++ b/net/pear-Net_Socket/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-Net_Socket
+# Date created: 24 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Socket
+PORTVERSION= 1.0.1
+CATEGORIES= net www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
+ @${CHOWN} -R root:wheel ${PEARDIR}/Net/Socket.php
+
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Socket/distinfo b/net/pear-Net_Socket/distinfo
new file mode 100644
index 000000000000..9de37b25e65d
--- /dev/null
+++ b/net/pear-Net_Socket/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Net_Socket-1.0.1.tgz) = f2b5f199a8586b855a549c2dccfbbd81
diff --git a/net/pear-Net_Socket/pkg-comment b/net/pear-Net_Socket/pkg-comment
new file mode 100644
index 000000000000..39f8c882c6c6
--- /dev/null
+++ b/net/pear-Net_Socket/pkg-comment
@@ -0,0 +1 @@
+PEAR Network Socket Interface
diff --git a/net/pear-Net_Socket/pkg-descr b/net/pear-Net_Socket/pkg-descr
new file mode 100644
index 000000000000..9bca37de98af
--- /dev/null
+++ b/net/pear-Net_Socket/pkg-descr
@@ -0,0 +1,7 @@
+Net_Socket is a PEAR class interface to TCP sockets.
+
+It provides blocking and non-blocking operation, with different reading
+and writing modes (byte-wise, block-wise, line-wise and special formats
+like network byte-order ip addresses).
+
+WWW: http://pear.php.net/manual/en/core.networking.net_socket.php
diff --git a/net/pear-Net_Socket/pkg-plist b/net/pear-Net_Socket/pkg-plist
new file mode 100644
index 000000000000..2426b9ad72eb
--- /dev/null
+++ b/net/pear-Net_Socket/pkg-plist
@@ -0,0 +1 @@
+%%PEARDIR%%/Net/Socket.php