aboutsummaryrefslogtreecommitdiff
path: root/net/pear-SOAP
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net/pear-SOAP
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'net/pear-SOAP')
-rw-r--r--net/pear-SOAP/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index d0ffd4fb1e60..fe986994d02a 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= net www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR SOAP Client/Server for PHP
-BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
-RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
USES= pear
@@ -18,8 +18,8 @@ PEAR_MAIL_DESC= PEAR::Mail support
PEAR_MAIL_MIME_DESC= PEAR::Mail::Mime support
PEAR_NET_DIME_DESC= PEAR::Net::DIME support
-PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail
-PEAR_MAIL_MIME_BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime
-PEAR_NET_DIME_BUILD_DEPENDS= ${PEARDIR}/Net/DIME.php:net/pear-Net_DIME
+PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
+PEAR_MAIL_MIME_BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime@${PHP_FLAVOR}
+PEAR_NET_DIME_BUILD_DEPENDS= ${PEARDIR}/Net/DIME.php:net/pear-Net_DIME@${PHP_FLAVOR}
.include <bsd.port.mk>