aboutsummaryrefslogtreecommitdiff
path: root/net/sixxs-heartbeatd/files
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2004-05-02 19:12:23 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2004-05-02 19:12:23 +0000
commit3718d819cf8717d981484f085926d309801e526c (patch)
tree1299124b82dfa91a37ef3e4e211adf97ea149ee4 /net/sixxs-heartbeatd/files
parent98acb6f8656c6a1e17fa37c01103f9230ce3e55f (diff)
downloadports-3718d819cf8717d981484f085926d309801e526c.tar.gz
ports-3718d819cf8717d981484f085926d309801e526c.zip
Notes
Diffstat (limited to 'net/sixxs-heartbeatd/files')
-rw-r--r--net/sixxs-heartbeatd/files/Makefile13
-rw-r--r--net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c14
-rw-r--r--net/sixxs-heartbeatd/files/patch-client_heartbeat.conf28
-rw-r--r--net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh29
4 files changed, 84 insertions, 0 deletions
diff --git a/net/sixxs-heartbeatd/files/Makefile b/net/sixxs-heartbeatd/files/Makefile
new file mode 100644
index 000000000000..1543d6d08524
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+.PATH: client common
+
+PROG= sixxs-heartbeatd
+SRCS= heartbeat-client.c hb.c common.c
+
+DPADD= ${LIBMD}
+LDADD= -lmd
+
+NOMAN= yes
+
+.include <bsd.prog.mk>
diff --git a/net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c b/net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c
new file mode 100644
index 000000000000..c2bb49457685
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/patch-client_heartbeat-client.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- client/heartbeat-client.c.orig Fri Apr 23 22:00:57 2004
++++ client/heartbeat-client.c Fri Apr 23 22:01:14 2004
+@@ -277,7 +277,7 @@
+ if (argc != 2)
+ {
+ fprintf(stderr,
+- "heartbeat-client <configfile>\n");
++ "sixxs-heartbeatd <configfile>\n");
+ return -1;
+ }
+
diff --git a/net/sixxs-heartbeatd/files/patch-client_heartbeat.conf b/net/sixxs-heartbeatd/files/patch-client_heartbeat.conf
new file mode 100644
index 000000000000..5721ca966fe0
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/patch-client_heartbeat.conf
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- client/heartbeat.conf.orig Fri Apr 23 22:02:02 2004
++++ client/heartbeat.conf Fri Apr 23 22:02:31 2004
+@@ -12,11 +12,11 @@
+ # os 'linux'
+
+ # Operating System (linux/freebsd/openbsd/netbsd/winxp)
+-os "linux"
++os "freebsd"
+
+ # Interface the tunnel should go over
+ # used for detecting the local IPv4 endpoint
+-ipv4_interface "eth0"
++ipv4_interface "tun0"
+
+ # IPv4 address of the POP (nlams01/nlams02/nlams04/demun01/iedub01/dkcop01)
+ # This is also the address to where heartbeats are sent
+@@ -39,7 +39,7 @@
+
+ # Interface to be used for the tunnel
+ # will be created on the OS's that need that
+-ipv6_interface "sixxs"
++ipv6_interface "gif0"
+
+ # The local and remote sides of the tunnel
+ ipv6_pop "2001:db8::1"
diff --git a/net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh b/net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh
new file mode 100644
index 000000000000..4d3c29ba95db
--- /dev/null
+++ b/net/sixxs-heartbeatd/files/sixxs-heartbeatd.sh
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: sixxs-heartbeatd
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD
+
+#
+# Add the following lines to /etc/rc.conf to enable sixxs-heartbeatd:
+#
+#sixxs_heartbeatd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=sixxs_heartbeatd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/sixxs-heartbeatd
+command_args=%%PREFIX%%/etc/heartbeat.conf
+required_files=%%PREFIX%%/etc/heartbeat.conf
+
+# set default
+sixxs_heartbeatd_enable=${sixxs_heartbeatd_enable:-"NO"}
+
+load_rc_config ${name}
+run_rc_command "$1"