aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/freebsd-bugzilla-cli
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-29 17:32:44 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-29 17:32:44 +0000
commitec79edeb05f4cec9be07c17c0a7e070678e646ef (patch)
tree3932498b4363865894b48a98c0c0418949ecfee9 /ports-mgmt/freebsd-bugzilla-cli
parenta332763fb729be39f758c57c63c9642a6ca1d26f (diff)
downloadports-ec79edeb05f4cec9be07c17c0a7e070678e646ef.tar.gz
ports-ec79edeb05f4cec9be07c17c0a7e070678e646ef.zip
CLI utilities and wrappers for FreeBSD's bugzilla
instance with emphasis on ports.Provides a consistent API which can have pluggable backends. WWW: https://github.com/pgollucci/freebsd-bugzilla-cli
Notes
Notes: svn path=/head/; revision=393188
Diffstat (limited to 'ports-mgmt/freebsd-bugzilla-cli')
-rw-r--r--ports-mgmt/freebsd-bugzilla-cli/Makefile29
-rw-r--r--ports-mgmt/freebsd-bugzilla-cli/distinfo2
-rw-r--r--ports-mgmt/freebsd-bugzilla-cli/pkg-descr4
-rw-r--r--ports-mgmt/freebsd-bugzilla-cli/pkg-plist11
4 files changed, 46 insertions, 0 deletions
diff --git a/ports-mgmt/freebsd-bugzilla-cli/Makefile b/ports-mgmt/freebsd-bugzilla-cli/Makefile
new file mode 100644
index 000000000000..415b7555b42e
--- /dev/null
+++ b/ports-mgmt/freebsd-bugzilla-cli/Makefile
@@ -0,0 +1,29 @@
+# Created by: Philip M. Gollucci <pgollucci@p6m7g8.com>
+# $FreeBSD$
+
+PORTNAME= freebsd-bugzilla-cli
+PORTVERSION= 0.0.1
+CATEGORIES= ports-mgmt
+MASTER_SITES= GH
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Interact with the FreeBSD bugzilla instance
+
+LICENSE= APACHE20
+
+OPTIONS_GROUP= BACKEND
+OPTIONS_GROUP_BACKEND= PYBUGZ
+OPTIONS_SET= PYBUGZ
+OPTIONS_SUB= yes
+
+PYBUGZ_DESC= use devel/pybugz for bugzilla interface
+PYBUGZ_RUN_DEPENDS= bugz:${PORTSDIR}/devel/pybugz
+
+DATADIR= ${PREFIX}/share/bz
+
+USE_GITHUB= yes
+GH_ACCOUNT= pgollucci
+
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/freebsd-bugzilla-cli/distinfo b/ports-mgmt/freebsd-bugzilla-cli/distinfo
new file mode 100644
index 000000000000..93034ebd02a7
--- /dev/null
+++ b/ports-mgmt/freebsd-bugzilla-cli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pgollucci-freebsd-bugzilla-cli-0.0.1_GH0.tar.gz) = fa86e4435cc2183d9bb574a7b0ff0d20ea1ea4a11298e1a9eabfd93efe97054b
+SIZE (pgollucci-freebsd-bugzilla-cli-0.0.1_GH0.tar.gz) = 2410
diff --git a/ports-mgmt/freebsd-bugzilla-cli/pkg-descr b/ports-mgmt/freebsd-bugzilla-cli/pkg-descr
new file mode 100644
index 000000000000..c9efa03a7d00
--- /dev/null
+++ b/ports-mgmt/freebsd-bugzilla-cli/pkg-descr
@@ -0,0 +1,4 @@
+CLI utilities and wrappers for FreeBSD's bugzilla instance with emphasis on
+ports. Provides a consistent API which can have pluggable backends.
+
+WWW: https://github.com/pgollucci/freebsd-bugzilla-cli
diff --git a/ports-mgmt/freebsd-bugzilla-cli/pkg-plist b/ports-mgmt/freebsd-bugzilla-cli/pkg-plist
new file mode 100644
index 000000000000..49a5ca23c864
--- /dev/null
+++ b/ports-mgmt/freebsd-bugzilla-cli/pkg-plist
@@ -0,0 +1,11 @@
+%%DATADIR%%/close.sh
+%%DATADIR%%/help.sh
+%%DATADIR%%/inprog.sh
+%%DATADIR%%/login.sh
+%%DATADIR%%/take.sh
+%%DATADIR%%/version.sh
+%%PYBUGZ%%%%DATADIR%%/pybugz/close.sh
+%%PYBUGZ%%%%DATADIR%%/pybugz/inprog.sh
+%%PYBUGZ%%%%DATADIR%%/pybugz/login.sh
+%%PYBUGZ%%%%DATADIR%%/pybugz/take.sh
+bin/bz