aboutsummaryrefslogtreecommitdiff
path: root/security/libssh2/Makefile
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2016-04-14 00:41:35 +0000
committerSofian Brabez <sbz@FreeBSD.org>2016-04-14 00:41:35 +0000
commit4c265c20b4f98754689e517d85a1622ee7fcdcba (patch)
tree58e7558008453cf25f83d583fd9926ca8c612ccc /security/libssh2/Makefile
parente15c68ce10821aee7796b48a844be9ef51d739e6 (diff)
downloadports-4c265c20b4f98754689e517d85a1622ee7fcdcba.tar.gz
ports-4c265c20b4f98754689e517d85a1622ee7fcdcba.zip
Notes
Diffstat (limited to 'security/libssh2/Makefile')
-rw-r--r--security/libssh2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 28a6ee26d4c8..06579114ec97 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libssh2
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTVERSION= 1.7.0
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/ \
@@ -13,6 +12,7 @@ MAINTAINER= sbz@FreeBSD.org
COMMENT= Library implementing the SSH2 protocol
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
@@ -52,4 +52,9 @@ post-build:
@${REINPLACE_CMD} -E -e '/Requires.private:/{s/[[:<:]]zlib[[:>:]]//;s/,,/,/;s/ ,/ /;s/,$$//;}' \
${WRKSRC}/libssh2.pc
+# allow maintainer to generate MAN3 manpages list (make extract is required before)
+x-generate-man3: extract
+ @(cd ${WRKSRC}/docs && ${LS} -1F *.3 | ${SORT} | ${CUT} -d '/' -f4 \
+ | ${GREP} -v template)
+
.include <bsd.port.post.mk>