aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Protocol-ACME/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-11 15:48:48 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-11 15:48:48 +0000
commit8c945941d80c8df243b2f3cf01c4e1b61601b4fb (patch)
treeeddd46482b28d514cf1f89d3eeaeb0ab7d125468 /security/p5-Protocol-ACME/Makefile
parenteb724048d8a6c02d57894d5ede90d55854491b6c (diff)
downloadports-8c945941d80c8df243b2f3cf01c4e1b61601b4fb.tar.gz
ports-8c945941d80c8df243b2f3cf01c4e1b61601b4fb.zip
Notes
Diffstat (limited to 'security/p5-Protocol-ACME/Makefile')
-rw-r--r--security/p5-Protocol-ACME/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/p5-Protocol-ACME/Makefile b/security/p5-Protocol-ACME/Makefile
new file mode 100644
index 000000000000..7d5cce1003d0
--- /dev/null
+++ b/security/p5-Protocol-ACME/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= Protocol-ACME
+PORTVERSION= 0.11
+DISTVERSIONPREFIX=v
+CATEGORIES= security perl5
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= Interface to the Let's Encrypt ACME API
+
+LICENSE= ART20
+
+RUN_DEPENDS= p5-Crypt-Format>=0.06:security/p5-Crypt-Format \
+ p5-Crypt-OpenSSL-Bignum>=0.06:security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-RSA>=0.28:security/p5-Crypt-OpenSSL-RSA \
+ p5-Digest-SHA>=5.95:security/p5-Digest-SHA \
+ p5-Log-Any>=1.032:devel/p5-Log-Any \
+ p5-JSON>=2.90:converters/p5-JSON \
+ p5-libwww>=6.13:www/p5-libwww
+
+USES= perl5
+USE_GITHUB= yes
+GH_ACCOUNT= sludin
+USE_PERL5= configure
+
+.include <bsd.port.mk>