aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Session-Token/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-27 21:21:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-27 21:21:54 +0000
commitbef55936cf0bf7253a625475ef46f5f36b11e99f (patch)
tree5d745ece224a1d14df9f8c7e7142e94663b86535 /security/p5-Session-Token/Makefile
parent033203568b990d5b7989748f85524443c6167195 (diff)
downloadports-bef55936cf0bf7253a625475ef46f5f36b11e99f.tar.gz
ports-bef55936cf0bf7253a625475ef46f5f36b11e99f.zip
Notes
Diffstat (limited to 'security/p5-Session-Token/Makefile')
-rw-r--r--security/p5-Session-Token/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/p5-Session-Token/Makefile b/security/p5-Session-Token/Makefile
new file mode 100644
index 000000000000..0b8494ddeb98
--- /dev/null
+++ b/security/p5-Session-Token/Makefile
@@ -0,0 +1,25 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Session-Token
+PORTVERSION= 1.008
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FRACTAL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Secure, efficient, simple random session token generation
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Session/Token/Token.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Session/Token/Token.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Session/Token/Token.so
+
+.include <bsd.port.mk>