aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Crypt_DiffieHellman
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-12 22:43:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-12 22:43:48 +0000
commit389e2371562a6efbf84f0514ebf56eb715b967d4 (patch)
tree4c35621ac5619348fe93184a1f2753df236c6b05 /security/pear-Crypt_DiffieHellman
parent90f0c534eb16e4e0bbf30e0c232563a5126569b5 (diff)
downloadports-389e2371562a6efbf84f0514ebf56eb715b967d4.tar.gz
ports-389e2371562a6efbf84f0514ebf56eb715b967d4.zip
Notes
Diffstat (limited to 'security/pear-Crypt_DiffieHellman')
-rw-r--r--security/pear-Crypt_DiffieHellman/Makefile27
-rw-r--r--security/pear-Crypt_DiffieHellman/distinfo3
-rw-r--r--security/pear-Crypt_DiffieHellman/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/security/pear-Crypt_DiffieHellman/Makefile b/security/pear-Crypt_DiffieHellman/Makefile
new file mode 100644
index 000000000000..c33a857038f1
--- /dev/null
+++ b/security/pear-Crypt_DiffieHellman/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Crypt_DiffieHellman
+# Date created: 27 Jan 2008
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_DiffieHellman
+PORTVERSION= 0.2.1
+CATEGORIES= security www pear
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= PEAR class implementing Diffie-Hellman Key Exchange protocol for PHP5
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= Crypt
+FILES= DiffieHellman.php DiffieHellman/Math.php DiffieHellman/Exception.php \
+ DiffieHellman/Math/Exception.php DiffieHellman/Math/BigInteger.php \
+ DiffieHellman/Math/BigInteger/Interface.php DiffieHellman/Math/BigInteger/Gmp.php \
+ DiffieHellman/Math/BigInteger/Exception.php DiffieHellman/Math/BigInteger/Bcmath.php
+TESTS= AllTests.php DiffieHellmanTest.php TestHelper.php TestConfiguration.php.dist
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_DiffieHellman/distinfo b/security/pear-Crypt_DiffieHellman/distinfo
new file mode 100644
index 000000000000..a98968abdd48
--- /dev/null
+++ b/security/pear-Crypt_DiffieHellman/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Crypt_DiffieHellman-0.2.1.tgz) = 288d50dafd44f524b7449f7e5f0e78f5
+SHA256 (PEAR/Crypt_DiffieHellman-0.2.1.tgz) = 3a28f74681a31d1a44a7d555fb1005aa012d6667c31ed6c0b547322e909b0f09
+SIZE (PEAR/Crypt_DiffieHellman-0.2.1.tgz) = 10555
diff --git a/security/pear-Crypt_DiffieHellman/pkg-descr b/security/pear-Crypt_DiffieHellman/pkg-descr
new file mode 100644
index 000000000000..7525d1a1411a
--- /dev/null
+++ b/security/pear-Crypt_DiffieHellman/pkg-descr
@@ -0,0 +1,6 @@
+Implementation of the Diffie-Hellman Key Exchange cryptographic protocol
+in PHP5. Enables two parties without any prior knowledge of each other
+establish a secure shared secret key across an insecure channel
+of communication.
+
+WWW: http://pear.php.net/package/Crypt_DiffieHellman/