aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2016-05-18 18:30:09 +0000
committerHiroki Sato <hrs@FreeBSD.org>2016-05-18 18:30:09 +0000
commit47483f2f4f7a0f79d5336f7acd454e05bb660b9c (patch)
treefd61cfefcf35ffbcbd116c58855511bfb1172bf4 /security
parent885198c68f97f9a78bbcf9f85c80ac8dc5d294c9 (diff)
downloadports-47483f2f4f7a0f79d5336f7acd454e05bb660b9c.tar.gz
ports-47483f2f4f7a0f79d5336f7acd454e05bb660b9c.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/trousers/files/patch-configure.in19
-rw-r--r--security/trousers/files/patch-src-tcs-Makefile.am17
-rw-r--r--security/trousers/files/patch-src-tcsd-Makefile.am18
-rw-r--r--security/trousers/files/patch-src-trspi-Makefile.am6
-rw-r--r--security/trousers/files/patch-src-tspi-Makefile.am13
5 files changed, 48 insertions, 25 deletions
diff --git a/security/trousers/files/patch-configure.in b/security/trousers/files/patch-configure.in
index e1b82658d938..489a28fb5fea 100644
--- a/security/trousers/files/patch-configure.in
+++ b/security/trousers/files/patch-configure.in
@@ -1,6 +1,15 @@
---- configure.in.orig 2014-04-24 18:05:43 UTC
-+++ configure.in
-@@ -72,6 +72,21 @@ AC_ARG_ENABLE(gcov,
+--- configure.in.orig 2014-04-25 03:05:43.000000000 +0900
++++ configure.in 2016-05-19 02:57:32.524179000 +0900
+@@ -52,7 +52,7 @@
+ AC_MSG_ERROR([$OPENSSL_INCLUDE_DIR or $OPENSSL_LIB_DIR doen't exist!])
+ else
+ AC_MSG_RESULT([yes])
+- CFLAGS="$CFLAGS -L$OPENSSL_LIB_DIR -I$OPENSSL_INCLUDE_DIR"
++ AC_SUBST([OPENSSL_INCLUDE_DIR])
+ AC_SUBST([OPENSSL_LIB_DIR])
+ fi],
+ [AC_MSG_RESULT([no])
+@@ -72,6 +72,21 @@
[CFLAGS="$CFLAGS -ftest-coverage -fprofile-arcs"
AC_MSG_RESULT([*** Enabling gcov at user request ***])],)
@@ -22,7 +31,7 @@
# profiling support
AC_ARG_ENABLE(gprof,
[AC_HELP_STRING([--enable-gprof], [enable profiling with gprof [default=off]])],
-@@ -356,6 +371,8 @@ AC_PROG_LIBTOOL
+@@ -356,6 +371,8 @@
AC_C_BIGENDIAN([AC_DEFINE(_BIG_ENDIAN, 1, [big-endian host])])
AC_CHECK_DECL(htole32, [AC_DEFINE(HTOLE_DEFINED, 1, [htole32 function is available])])
AC_CHECK_HEADER(sys/byteorder.h, [AC_DEFINE(HAVE_BYTEORDER_H, 1, [sys/byteorder.h header])])
@@ -31,7 +40,7 @@
AC_CHECK_FUNC(daemon, [ AC_DEFINE(HAVE_DAEMON, 1, [daemon function is available]) ])
if test "x${GCC}" = "xyes"; then
-@@ -363,6 +380,7 @@ if test "x${GCC}" = "xyes"; then
+@@ -363,6 +380,7 @@
fi
CFLAGS="$CFLAGS -I../include \
diff --git a/security/trousers/files/patch-src-tcs-Makefile.am b/security/trousers/files/patch-src-tcs-Makefile.am
index 4746998522ff..820f81d98a1c 100644
--- a/security/trousers/files/patch-src-tcs-Makefile.am
+++ b/security/trousers/files/patch-src-tcs-Makefile.am
@@ -1,12 +1,21 @@
---- src/tcs/Makefile.am.orig 2014-04-24 18:05:44 UTC
-+++ src/tcs/Makefile.am
+--- src/tcs/Makefile.am.orig 2014-04-25 03:05:44.000000000 +0900
++++ src/tcs/Makefile.am 2016-05-19 03:02:33.269090000 +0900
@@ -1,4 +1,4 @@
-noinst_LIBRARIES=libtcs.a
+noinst_LIBRARIES=libtcs.a libtcs_emu.a
CFLAGS+=-I${top_srcdir}/src/include
libtcs_a_LIBADD=${top_builddir}/src/tddl/libtddl.a
-@@ -140,3 +140,143 @@ if TSS_BUILD_CMK
+@@ -91,7 +91,7 @@
+ if TSS_BUILD_KEY
+ libtcs_a_SOURCES+=tcsi_key.c tcs_key.c tcs_key_mem_cache.c tcs_context_key.c rpc/@RPC@/rpc_key.c \
+ crypto/@CRYPTO_PACKAGE@/crypto.c
+-libtcs_a_CFLAGS+=-DTSS_BUILD_KEY
++libtcs_a_CFLAGS+=-DTSS_BUILD_KEY -I@OPENSSL_INCLUDE_DIR@
+ endif
+ if TSS_BUILD_MAINT
+ libtcs_a_SOURCES+=tcsi_maint.c rpc/@RPC@/rpc_maint.c
+@@ -140,3 +140,143 @@
libtcs_a_SOURCES+=tcsi_cmk.c rpc/@RPC@/rpc_cmk.c
libtcs_a_CFLAGS+=-DTSS_BUILD_CMK
endif
@@ -101,7 +110,7 @@
+if TSS_BUILD_KEY
+libtcs_emu_a_SOURCES+=tcsi_key.c tcs_key.c tcs_key_mem_cache.c tcs_context_key.c rpc/@RPC@/rpc_key.c \
+ crypto/@CRYPTO_PACKAGE@/crypto.c
-+libtcs_emu_a_CFLAGS+=-DTSS_BUILD_KEY
++libtcs_emu_a_CFLAGS+=-DTSS_BUILD_KEY -I@OPENSSL_INCLUDE_DIR@
+endif
+if TSS_BUILD_MAINT
+libtcs_emu_a_SOURCES+=tcsi_maint.c rpc/@RPC@/rpc_maint.c
diff --git a/security/trousers/files/patch-src-tcsd-Makefile.am b/security/trousers/files/patch-src-tcsd-Makefile.am
index 8c6cd754468b..2a067281633c 100644
--- a/security/trousers/files/patch-src-tcsd-Makefile.am
+++ b/security/trousers/files/patch-src-tcsd-Makefile.am
@@ -1,17 +1,19 @@
---- src/tcsd/Makefile.am.orig 2014-04-24 18:05:44 UTC
-+++ src/tcsd/Makefile.am
-@@ -1,4 +1,4 @@
+--- src/tcsd/Makefile.am.orig 2014-04-25 03:05:44.000000000 +0900
++++ src/tcsd/Makefile.am 2016-05-19 03:00:08.951991000 +0900
+@@ -1,11 +1,17 @@
-sbin_PROGRAMS=tcsd
+sbin_PROGRAMS=tcsd tcsd_emu
- tcsd_CFLAGS=-DAPPID=\"TCSD\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I${top_srcdir}/src/include -fPIE -DPIE
- tcsd_LDADD=${top_builddir}/src/tcs/libtcs.a ${top_builddir}/src/tddl/libtddl.a -lpthread @CRYPTOLIB@
-@@ -6,6 +6,12 @@ tcsd_LDFLAGS=-pie -Wl,-z,relro -Wl,-z,no
+-tcsd_CFLAGS=-DAPPID=\"TCSD\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I${top_srcdir}/src/include -fPIE -DPIE
+-tcsd_LDADD=${top_builddir}/src/tcs/libtcs.a ${top_builddir}/src/tddl/libtddl.a -lpthread @CRYPTOLIB@
++tcsd_CFLAGS=-DAPPID=\"TCSD\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I${top_srcdir}/src/include -fPIE -DPIE -I@OPENSSL_INCLUDE_DIR@
++tcsd_LDADD=${top_builddir}/src/tcs/libtcs.a ${top_builddir}/src/tddl/libtddl.a -lpthread -L@OPENSSL_LIB_DIR@ @CRYPTOLIB@
+ tcsd_LDFLAGS=-pie -Wl,-z,relro -Wl,-z,now
tcsd_SOURCES=svrside.c tcsd_conf.c tcsd_threads.c platform.c
-+tcsd_emu_CFLAGS=-DAPPID=\"TCSD\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I${top_srcdir}/src/include -fPIE -DPIE
-+tcsd_emu_LDADD=${top_builddir}/src/tcs/libtcs_emu.a -ltddl -L${LOCALBASE}/lib/tddl_emu -lpthread @CRYPTOLIB@
++tcsd_emu_CFLAGS=-DAPPID=\"TCSD\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I${top_srcdir}/src/include -fPIE -DPIE -I@OPENSSL_INCLUDE_DIR@
++tcsd_emu_LDADD=${top_builddir}/src/tcs/libtcs_emu.a -ltddl -L${LOCALBASE}/lib/tddl_emu -lpthread -L@OPENSSL_LIB_DIR@ @CRYPTOLIB@
+tcsd_emu_LDFLAGS=-pie -Wl,-z,relro -Wl,-z,now -Wl,-rpath=${LOCALBASE}/lib/tddl_emu:${LOCALBASE}/lib
+
+tcsd_emu_SOURCES=svrside.c tcsd_conf.c tcsd_threads.c platform.c
diff --git a/security/trousers/files/patch-src-trspi-Makefile.am b/security/trousers/files/patch-src-trspi-Makefile.am
index 8b7f1bb90a64..e834550f5121 100644
--- a/security/trousers/files/patch-src-trspi-Makefile.am
+++ b/security/trousers/files/patch-src-trspi-Makefile.am
@@ -1,12 +1,12 @@
---- src/trspi/Makefile.am.orig 2014-04-24 18:05:44 UTC
-+++ src/trspi/Makefile.am
+--- src/trspi/Makefile.am.orig 2014-04-25 03:05:44.000000000 +0900
++++ src/trspi/Makefile.am 2016-05-19 03:16:29.786606000 +0900
@@ -1,7 +1,8 @@
noinst_LTLIBRARIES=libtrousers.la
libtrousers_la_SOURCES=trousers.c crypto/@CRYPTO_PACKAGE@/hash.c
-libtrousers_la_CFLAGS=-DAPPID=\"TSPI\" -I${top_srcdir}/src/include
+libtrousers_la_CFLAGS=-DAPPID=\"TSPI\" -I${top_srcdir}/src/include \
-+ -I${ICONV_PREFIX}/include
++ -I${ICONV_PREFIX}/include -I@OPENSSL_INCLUDE_DIR@
if TSS_BUILD_ASYM_CRYPTO
libtrousers_la_SOURCES+=crypto/@CRYPTO_PACKAGE@/rsa.c
diff --git a/security/trousers/files/patch-src-tspi-Makefile.am b/security/trousers/files/patch-src-tspi-Makefile.am
index 31672e1262d1..66be8ad0b6a5 100644
--- a/security/trousers/files/patch-src-tspi-Makefile.am
+++ b/security/trousers/files/patch-src-tspi-Makefile.am
@@ -1,11 +1,14 @@
---- src/tspi/Makefile.am.orig 2014-04-24 18:05:44 UTC
-+++ src/tspi/Makefile.am
-@@ -17,7 +17,7 @@ libtspi_la_LIBADD=${top_builddir}/src/tr
+--- src/tspi/Makefile.am.orig 2014-04-25 03:05:44.000000000 +0900
++++ src/tspi/Makefile.am 2016-05-19 03:04:18.883005000 +0900
+@@ -17,9 +17,9 @@
# 5. If any interfaces have been added since the last public release, then increment age.
# 6. If any interfaces have been removed since the last public release, then set age to 0.
-libtspi_la_LDFLAGS=-version-info 3:0:2 -lpthread @CRYPTOLIB@
-+libtspi_la_LDFLAGS=-version-info 3:0:2 -lpthread @CRYPTOLIB@ -L${ICONV_PREFIX}/lib ${ICONV_LIB}
++libtspi_la_LDFLAGS=-version-info 3:0:2 -lpthread -L@OPENSSL_LIB_DIR@ @CRYPTOLIB@ -L${ICONV_PREFIX}/lib ${ICONV_LIB}
- libtspi_la_CFLAGS=-I$(top_srcdir)/src/include -DAPPID=\"TSPI\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\"
+-libtspi_la_CFLAGS=-I$(top_srcdir)/src/include -DAPPID=\"TSPI\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\"
++libtspi_la_CFLAGS=-I$(top_srcdir)/src/include -DAPPID=\"TSPI\" -DVAR_PREFIX=\"@localstatedir@\" -DETC_PREFIX=\"@sysconfdir@\" -I@OPENSSL_INCLUDE_DIR@
+ libtspi_la_SOURCES=log.c \
+ spi_utils.c \