aboutsummaryrefslogtreecommitdiff
path: root/sysutils/UEFITool/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2017-03-20 09:43:51 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2017-03-20 09:43:51 +0000
commit0624c3b769880ee5f06d3ded12e538e71e2455dd (patch)
treeb58b7d858eb29bd221b67415f320c41696cd557a /sysutils/UEFITool/Makefile
parent5cd92ee25505240010d148adc010c0e9987ff13e (diff)
downloadports-0624c3b769880ee5f06d3ded12e538e71e2455dd.tar.gz
ports-0624c3b769880ee5f06d3ded12e538e71e2455dd.zip
Notes
Diffstat (limited to 'sysutils/UEFITool/Makefile')
-rw-r--r--sysutils/UEFITool/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/UEFITool/Makefile b/sysutils/UEFITool/Makefile
new file mode 100644
index 000000000000..ed2f2a185ac2
--- /dev/null
+++ b/sysutils/UEFITool/Makefile
@@ -0,0 +1,31 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= UEFITool
+PORTVERSION= 40
+CATEGORIES= sysutils
+
+MAINTAINER= pkubaj@anongoth.pl
+COMMENT= UEFI images parser
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= LongSoft
+GH_TAGNAME= A${PORTVERSION}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GH_TAGNAME}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+USES= qmake:outsource
+USE_GL= gl
+USE_QT5= buildtools_build core gui widgets qmake_build
+
+pre-install:
+ ${STRIP_CMD} ${WRKDIR}/.build/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/.build/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>