aboutsummaryrefslogtreecommitdiff
path: root/sysutils/android-file-transfer
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-09-27 18:25:17 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-09-27 18:25:17 +0000
commit55be9c95f5e7fa63263e3b38cc78ea638d510d8e (patch)
treef087a592e5c1673bb1690aaf1b7a4a41b384e9e0 /sysutils/android-file-transfer
parent25b98debb634a476a3170eec7eebe2fde1e865be (diff)
downloadports-55be9c95f5e7fa63263e3b38cc78ea638d510d8e.tar.gz
ports-55be9c95f5e7fa63263e3b38cc78ea638d510d8e.zip
sysutils/android-file-transfer: enslave GUI and expose CLI option
Catering package-only users that want Qt4 flavor or just non-GUI parts. COMMENT and pkg-descr (both plural) can be improved in future.
Notes
Notes: svn path=/head/; revision=422824
Diffstat (limited to 'sysutils/android-file-transfer')
-rw-r--r--sysutils/android-file-transfer/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/sysutils/android-file-transfer/Makefile b/sysutils/android-file-transfer/Makefile
index 987e52fda202..18bad2aeb914 100644
--- a/sysutils/android-file-transfer/Makefile
+++ b/sysutils/android-file-transfer/Makefile
@@ -4,6 +4,7 @@ PORTNAME= android-file-transfer
DISTVERSIONPREFIX= v
DISTVERSION= 3.0-10
DISTVERSIONSUFFIX= -g40640fb
+PORTREVISION?= 1
CATEGORIES= sysutils
MAINTAINER= jbeich@FreeBSD.org
@@ -15,17 +16,24 @@ USE_GITHUB= yes
GH_ACCOUNT= whoozle
GH_PROJECT= ${PORTNAME}-linux
-USES= cmake compiler:c++11-lib localbase pkgconfig readline
+USES= cmake compiler:c++11-lib localbase pkgconfig
CMAKE_ARGS= -DUSB_BACKEND_LIBUSB=on -DBUILD_QT_UI=off
-PLIST_FILES= bin/aft-mtp-cli
-OPTIONS_DEFINE= FUSE
-OPTIONS_DEFAULT=FUSE QT5
+OPTIONS_DEFAULT=CLI FUSE
+OPTIONS_MULTI= COMP
+OPTIONS_MULTI_COMP= CLI FUSE
OPTIONS_RADIO= GUI
OPTIONS_RADIO_GUI= QT4 QT5
+OPTIONS_EXCLUDE?=${OPTIONS_RADIO_GUI}
# XXX http://lists.dragonflybsd.org/pipermail/users/2016-September/313064.html
OPTIONS_EXCLUDE_DragonFly= FUSE
+COMP_DESC= Components
+
+CLI_DESC= CLI (Command-Line Interface) support
+CLI_USES= readline
+CLI_PLIST_FILES=bin/aft-mtp-cli
+
FUSE_USES= fuse
FUSE_CMAKE_BOOL=BUILD_FUSE
FUSE_PLIST_FILES=bin/aft-mtp-mount
@@ -44,4 +52,7 @@ QT5_PLIST_FILES=bin/android-file-transfer \
CONFIGURE_ENV+= PKG_CONFIG_PATH="${FILESDIR}"
.endif
+post-patch-CLI-off:
+ @${REINPLACE_CMD} '/subdirectory(cli)/d' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>