aboutsummaryrefslogtreecommitdiff
path: root/sysutils/apcupsd/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-09-04 23:39:38 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-09-04 23:39:38 +0000
commit5158fdadabc0e2db1f8b1cd8a7d456bc999d83d3 (patch)
tree5fabcc634cecf93be203c8148aa87c49a54dee8d /sysutils/apcupsd/Makefile
parentf52117b52944f049bdcf74db61c4f89a54cd7b68 (diff)
downloadports-5158fdadabc0e2db1f8b1cd8a7d456bc999d83d3.tar.gz
ports-5158fdadabc0e2db1f8b1cd8a7d456bc999d83d3.zip
sysutils/apcupsd: Add patch to fix APC BE600M1 reporting
Patch not enabled as default (initially), so we can have more users testing it. PR: 249041 Submitted by: Derek Schrock <dereks@lifeofadishwasher.com> Differential Revision: https://reviews.freebsd.org/D26259
Notes
Notes: svn path=/head/; revision=547577
Diffstat (limited to 'sysutils/apcupsd/Makefile')
-rw-r--r--sysutils/apcupsd/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 93f9b130241f..7e9bf9df70b1 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apcupsd
PORTVERSION= 3.14.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20-%20Stable/${PORTVERSION}
@@ -31,7 +31,7 @@ CONFLICTS_INSTALL= apcctrl
OPTIONS_DEFINE= APCDUMB_DRV APCSMART_DRV CGI CLIENT_ONLY GAPCMON MODBUS \
MODBUS_USB PCNET_DRV SHUTDOWN_POWEROFF SNMP_DRV SNMP_DRV_OLD \
- TCP_WRAPPERS TEST_DRV USB_DRV
+ TCP_WRAPPERS TEST_DRV USB_DRV USB_REPORTING
OPTIONS_DEFAULT= APCDUMB_DRV APCSMART_DRV MODBUS MODBUS_USB PCNET_DRV \
SNMP_DRV TCP_WRAPPERS USB_DRV
OPTIONS_SUB= yes
@@ -50,6 +50,7 @@ SNMP_DRV_OLD_DESC= Old SNMP driver support
TCP_WRAPPERS_DESC= ${LIBWRAP_DESC}
TEST_DRV_DESC= Test driver support
USB_DRV_DESC= USB driver support
+USB_REPORTING_DESC= Experimental patch for faulty USB reporting
APCDUMB_DRV_CONFIGURE_ENABLE= dumb
APCSMART_DRV_CONFIGURE_ENABLE= apcsmart
@@ -75,6 +76,8 @@ TCP_WRAPPERS_CONFIGURE_WITH= libwrap=yes
TEST_DRV_CONFIGURE_ENABLE= test
USB_DRV_CONFIGURE_ENABLE= usb
+USB_REPORTING_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-usb-reporting
+
.include <bsd.port.options.mk>
post-patch-SHUTDOWN_POWEROFF-on: