aboutsummaryrefslogtreecommitdiff
path: root/sysutils/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-10-01 14:36:47 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-10-01 14:54:55 +0000
commit7545575ac130685bb989260e03d2288a2c46c7f5 (patch)
tree829444acf602d290d6a3eb82b5ccd2c5229d2449 /sysutils/e2fsprogs/Makefile
parent14e733a6bb4b99ae6fbbab6cb9d6b133583daabb (diff)
downloadports-7545575ac130685bb989260e03d2288a2c46c7f5.tar.gz
ports-7545575ac130685bb989260e03d2288a2c46c7f5.zip
sysutils/e2fsprogs: 2/2 add a port for /sbin fsck'ing ext2/ext3/ext4
This is the second half of the e2fsprogs commit to permit having a big hier(7)-clean e2fsprogs port that does not ever reach into /sbin, now called e2fsprogs-core, and this new port that will copy from ${LOCALBASE} to /sbin so that /usr can reside on an ext2/ext3/ext4 file system and still be fsck'd at boot time.
Diffstat (limited to 'sysutils/e2fsprogs/Makefile')
-rw-r--r--sysutils/e2fsprogs/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
new file mode 100644
index 000000000000..a59f478893cd
--- /dev/null
+++ b/sysutils/e2fsprogs/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= e2fsprogs
+CATEGORIES= sysutils
+PORTVERSION= 1.46.5
+PORTREVISION= 5
+BUILD_DEPENDS= e2fsprogs-core>=${PORTVERSION}:sysutils/e2fsprogs-core
+RUN_DEPENDS= ${BUILD_DEPENDS}
+DISTFILES= # empty
+NO_BUILD= yes
+LICENSE= GPLv2+
+USES= cpe
+CPE_VENDOR= e2fsprogs_project
+
+MAINTAINER= mandree@FreeBSD.org
+COMMENT= Wrapper to install e2fsprogs into /sbin
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/sbin
+ ${CP} -p ${LOCALBASE}/sbin/fsck_ext2fs ${STAGEDIR}/sbin
+ ${CP} -p ${LOCALBASE}/sbin/e2fsck ${STAGEDIR}/sbin
+
+.include <bsd.port.mk>