aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hfsutils/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-23 03:53:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-23 03:53:41 +0000
commit0cbf270d03be8ece025c7db5539e2b2f146ff23c (patch)
tree2eaee9926e35fbebebebda255035aded43b98496 /sysutils/hfsutils/Makefile
parent86facf381ebe3dcef9fccfcd876428ea42648846 (diff)
downloadports-0cbf270d03be8ece025c7db5539e2b2f146ff23c.tar.gz
ports-0cbf270d03be8ece025c7db5539e2b2f146ff23c.zip
Notes
Diffstat (limited to 'sysutils/hfsutils/Makefile')
-rw-r--r--sysutils/hfsutils/Makefile77
1 files changed, 77 insertions, 0 deletions
diff --git a/sysutils/hfsutils/Makefile b/sysutils/hfsutils/Makefile
new file mode 100644
index 000000000000..6df1a64bdf88
--- /dev/null
+++ b/sysutils/hfsutils/Makefile
@@ -0,0 +1,77 @@
+# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
+# $FreeBSD$
+
+PORTNAME= hfsutils
+PORTVERSION= 3.2.6
+PORTREVISION= 3
+CATEGORIES= emulators tk
+MASTER_SITES= ftp://ftp.mars.org/pub/hfs/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Utilities for accessing Apple's HFS volumes
+
+LICENSE= GPLv2
+
+CONFLICTS= hfs-[0-9]*
+
+GNU_CONFIGURE= yes
+ALL_TARGET= all hfsck/hfsck
+
+MAN1= hattrib.1 \
+ hcd.1 \
+ hcopy.1 \
+ hdel.1 \
+ hdir.1 \
+ hformat.1 \
+ hfsutils.1 \
+ hls.1 \
+ hmkdir.1 \
+ hmount.1 \
+ hpwd.1 \
+ hrename.1 \
+ hrmdir.1 \
+ humount.1 \
+ hvol.1
+
+OPTIONS_DEFINE= TCLTK DOCS
+TCLTK_DESC= Build tools that require Tcl/Tk support
+
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTCLTK}
+USE_TCL= 84+
+USE_TK= 84+
+
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+
+MAN1+= hfs.1 \
+ hfssh.1 \
+ xhfs.1
+
+PLIST_FILES+= bin/hfs \
+ bin/hfssh \
+ bin/xhfs
+.else
+CONFIGURE_ARGS= --without-tcl --without-tk
+.endif
+
+post-patch:
+# Unbreak against Tcl 8.6
+ @${ECHO_CMD} '#define USE_INTERP_RESULT 1' >> ${WRKSRC}/config.h.in
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hfsck/hfsck ${PREFIX}/bin
+.if ${PORT_OPTIONS:MTCLTK}
+ @${CHMOD} 755 ${PREFIX}/bin/hfs
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+. for f in BLURB CHANGES README TODO doc/*.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>